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1.  Grundbegriffe 

1.1  Der Derive-Bildschirm 
   
Nach dem Starten von Derive erscheint der folgende Bildschirm: 
 
 

  
 
Im oberen Teil des Schirms befindet sich ein (leeres) Algebrafenster mit zugehöriger Titelleiste, 
Menüleiste und Befehls-Symbolleiste. Die Menübefehle werden wie bei allen anderen Win-
dows-Programmen bedient. Häufig benötigte Menübefehle stehen zusätzlich als Symbole in der 
Befehls-Symbolleiste zur Verfügung. 
 
Die Zeile mit dem blinkenden Cursor im unteren Teil des Bildschirms ist die Authorzeile. Man 
arbeitet mit Derive, indem man mathematische Ausdrücke über die Authorzeile ins Algebra-
fenster eingibt und dann mit Hilfe der Menübefehle umformt. 
 
Griechische Buchstaben und mathematische Sonderzeichen, die auf der Tastatur nicht verfüg-
bar sind, können durch Anklicken der entsprechenden Symbole in der Greek Symbol-Leiste 
bzw. der Math Symbol-Leiste in der Authorzeile dargestellt werden.  
 
Mit dem Menübefehl File>Exit  kann man das Arbeiten mit Derive beenden.  
 

1.2  Eingeben von Ausdrücken 
   
Eine zentrale Rolle bei der Bedienung von Derive spielt die Authorzeile, über die  mathemati-
sche Ausdrücke und auch erläuternde Texte (diese sind in Anführungszeichen zu setzen) ins 
Algebrafenster eingegeben werden können. 
 
Die Authorzeile kann durch Drücken der Funktionstaste F2 (oder durch Anklicken mit der 
linken Maustaste) aktiviert und durch Drücken der Esc-Taste deaktiviert werden.  



   
Tippt man, zum Beispiel, den Term  3(2+8+1)/(1+5)^2  ein und drückt abschließend die En-
ter-Taste, so wird dieser Ausdruck im Algebrafenster in Bruchschreibweise dargestellt und mit 
einer Zeilennummer versehen.  
 
Tastenbelegungen in der Authorzeile: 
 
Tab Markiert den gesamten Ausdruck in der Eingabezeile 
Shift→→→→ Markiert das Zeichen unter dem Cursor 
Entf  Löscht alle markierten Zeichen 
Rücktaste Löscht das Zeichen links vom Cursor 
  
Str z Macht das letzte Löschen rückgängig 
Einfg Schaltet zwischen Einfüge- und Überschreibmodus um 
←←←← , →→→→ Bewegt den Cursor um eine Stelle nach links bzw. rechts 
Pos1, Ende Bewegt den Cursor an den Zeilenanfang bzw. an das Zeilenende 
  

1.3  Vereinfachen von Ausdrücken  
  
Anwählen des Menübefehls Simplify > B asic (oder Anklicken des Simplify-Symbols in der 
Befehssymbolleiste)  bewirkt, dass der im Algebrafenster aktuell markierte Ausdruck verein-
facht wird.  
 

So wird, zum Beispiel, der Term 
)²51(

)182(3
+

++⋅  aus Zeile 1 zu 
12
11  vereinfacht. Dieses Ergebnis 

wird in einer neuen Bildschirmzeile dargestellt.   
 
 
Hinweise: 
- Markiert man (mit Hilfe der Tastenkombinationen Shift  ↓↓↓↓, Shift ↑↑↑↑, Shift →→→→ bzw. Shift  

←←←←) nur einen Teil eines Ausdrucks, zum Beispiel nur den Subterm  (2+8+1)  in Zeile 1, so 
wird beim Anwenden von Simplify  nur dieser Subterm innerhalb des Terms vereinfacht.  

 
- Schließt man die Eingabe eines Ausdrucks in der Authorzeile statt mit Enter mit der Tas-

tenkombination Strg  Enter ab, so wird der Ausdruck im Algebrafenster dargestellt und 
außerdem in der nächsten Bildschirmzeile das Ergebnis von Simplify > B asic ausgegeben. 

 
- Dauert das Vereinfachen eines Ausdrucks zu lange, so kann man die laufende Berechnung 

jederzeit durch Drücken der Esc-Taste abbrechen. 
  
 

1.4  Ermitteln von Näherungswerten  
  
Derive führt numerische Operationen im allgemeinen in einer rationalen Arithmetik durch. Ra-
tionale Zahlen werden als gekürzte Brüche dargestellt, irrationale Zahlen verbleiben in symboli-



scher Schreibweise. So führt, zum Beispiel, das Vereinfachen des Terms aus Zeile 1 mit dem 
Simplify-Symbol auf die rationale Zahl 11/12. Dezimale Näherungswerte einer numerischen 
Größe erhält man, indem man das Approx-Symbol anklickt (oder den Menübefehl Simplify > 
Approximate anwählt) .  
  
Das Approx-Symbol liefert einen Näherungswert entsprechend der eingestellten Stellengenau-
igkeit (üblicherweise 10 signifikante Stellen). Der Menübefehl Simplify > A pproximate er-
möglicht es, die Zahl der signifikanten Stellen zu wählen.   
 
Schließt man die Eingabe eines Ausdrucks in der Authorzeile statt mit Enter mit der Tasten-
kombination Shift  Enter ab, so wird der Ausdruck im Algebrafenster dargestellt und außer-
dem in der nächsten Bildschirmzeile das Ergebnis von Simplify > A pproximate ausgegeben. 
 

1.5 Markieren von Ausdrücken im Algebrafenster 
 
Einzelne Bildschirmzeilen im Algebrafenster können markiert werden 
 
- durch Anklicken der jeweiligen Zeile mit der linken Maustaste oder 
- mit Hilfe der Cursortasten ↑↑↑↑ und  ↓↓↓↓, die die Markierung um eine Zeile nach oben bzw. un-

ten bewegen oder 
- mit Hilfe der Bild ↑↑↑↑- und der Bild ↓↓↓↓-Taste, die die Markierung um eine Bildschirmhöhe 

nach oben bzw. unten bewegen oder 
- mit Hilfe der Pos1- und der Ende-Taste, die die Markierung zum ersten bzw. zum letzten 

Ausdruck des Algebrafensters bewegen.  
 
Ein Subterm eines Ausdrucks kann markiert werden 
 
- durch Anklicken dieses Subterms mit der Maus oder 
- mit Hilfe der Tastenkombinationen Shift  ↓↓↓↓ und Shift  ↑↑↑↑ (markiert jeweils den nächsttiefe-

ren / nächsthöheren Teilterm innerhalb des Ausdrucks) bzw. Shift →→→→ und Shift  ←←←← (mar-
kiert abwechselnd gleichwertige Teilterme)  

 
Ein Block aus mehreren Algebrafenster-Zeilen kann markiert werden 
 
- durch Anklicken der ersten Zeile dieses Blocks mit der linken Maustaste und Bewegen der 

Maus mit gedrückter linker Maustaste zur letzten Zeile des Blocks oder 
- durch Anklicken der ersten Zeile dieses Blocks, Drücken der Shift-Taste und (bei gedrück-

ter Shift-Taste) Anklicken der letzten Zeile des Blocks mit der linken Maustaste  
- Mit Hilfe der Tastenkombination Strg  Shift  ↓↓↓↓ 
 
 

1.6  Faktorisieren und Ausmultiplizieren von Termen 
  
Der Menübefehl Simplify>F actor ermöglicht es, Ausdrücke bezüglich einer, mehrerer oder 
aller seiner Variablen zu faktorisieren. Umgekehrt kann man mit dem Menübefehl Simpli-



fy>Expand Ausdrücke ausmultiplizieren. Markiert man nur einen Teil eines Ausdrucks, so 
wird nur dieser faktorisiert oder ausmultipliziert.  
 
Natürliche Zahlen werden durch Simplify>F actor in ihre Primfaktoren zerlegt. Bei Variable-
nausdrücken kann man die Tiefe der Zerlegung festlegen (Trivial,  SquareFree, Rational, 
Radical oder Complex) bzw. angeben, nach welchen der vorkommenden Variablen und in 
welcher Variablenrangordnung man faktorisieren will. 
  
Beispiele:  
-  Markieren der Zahl 1030+1 im Algebrafenster und Anwenden des Menübefehls Simpli-

fy>Factor liefert die Primfaktorzerlegung   
 61 ⋅⋅⋅⋅101 ⋅⋅⋅⋅ 3541 ⋅⋅⋅⋅ 9901 ⋅⋅⋅⋅ 27961 ⋅⋅⋅⋅ 4188901 ⋅⋅⋅⋅ 39526741 
 
-  Markieren von x²+4, Anwenden von Simlify > F actor  und Anklicken von Complex er-

gibt (x + 2î)(x - 2î) 
 
-  Markieren von  2x(x-3)²  und Anwenden von Simplify > E xpand ergibt  2x3-12x²+18x 
 
 

1.7 Substituieren in Termen 
  
Mit dem Menübefehl Simplify > V ariable Substitution  (bzw. durch Anklicken des SUB-
Symbols in der Befehlssymbolleiste) kann man Variablen neue Werte zuweisen, mit Simplify > 
Subexpression Substitution  ganze Teilterme durch andere Ausdrücke ersetzen. 
  

1.7.1 Neubelegung von Variablen in einem Term: 
  
- Zunächst markiert man im Algebrafenster den Ausdruck, in dem substituiert werden soll.  

- Nach Aufruf von  Simplify > V ariable Substitution erscheint ein Dialogfeld, das links 
eine Liste aller in diesem Ausdruck vorkommenden Variablennamen anzeigt.  

- Jeweils eine Variable dieser Liste ist blau markiert. Im New Value-Feld des Dialogfelds 
kann ein neuer Wert für diese Variable eingetippt werden. 

- Mit der Tastenkombination Shift ↓↓↓↓ (oder durch Anklicken mit der Maus) kann man der 
Reihe nach alle anderen Variablen der Liste markieren, und jeweils im New Value-Feld die 
gewünschten neuen Belegungen eintippen. Wird für eine Variable kein Wert eingegeben, so 
bleibt sie unverändert. 

- Nach Durchführen aller Neubelegungen verlässt man das Dialogfeld durch Anklicken des 
OK-  oder des Simplify -Feldes.  

 
Beispiel:  
Geben Sie ax²+bx+c ins Algebrafenster ein. 
a) Setzen Sie für a=2, für b=3 und für c=4 ein.  
b) Ersetzen Sie x durch 3y-1 und vereinfachen Sie den erhaltenen Term. 



c) Vertauschen Sie in ax²+bx+c die Variablen a und c.   
  

1.7.2 Neubelegung eines Teilausdrucks: 
  
- Markiert man nur einen Teil eines Ausdrucks, und wählt dann Simplify > Subexpression 

Substitution an, so erscheint ein Dialogfeld, in dem die gewünschte neue Belegung des 
markierten Teilausdrucks eingegeben werden kann. 

- Außerdem kann man entscheiden, ob der Teilausdruck nur einmalig an der markierten Stel-
le (One) oder im gesamten Term (All ) ersetzt werden soll. 

   
Beispiel:  
Geben Sie den Ausdruck (3+xy)/(1+xy)  ein, markieren Sie  xy und ersetzen Sie dann  
a) beide vorhandenen Teilterme xy durch u,  
b) nur den Teilausdruck xy im Zähler durch u. 
  

1.8 Editieren von Ausdrücken 
 
Der Menübefehl Edit > Object (bzw. Drücken der Enter-Taste) bewirkt, dass der im Algebra-
fenster aktuell markierte Ausdruck in der Authorzeile editiert wird.  
Nach Verlassen der Authorzeile mit der Enter-Taste wird der markierte Ausdruck im Algebra-
fenster durch den neuen Inhalt der Authorzeile ersetzt.  
 
Außerdem kann man Ausdrücke des Algebrafensters mit Hilfe der Funktionstasten F3 und F4 
in die Authorzeile kopieren:   
- F3 kopiert einen im Algebrafenster markierten Ausdruck und fügt ihn an der aktuellen Cur-

sorposition in der Authorzeile ein. 
- F4 kopiert einen im Algebrafenster markierten Ausdruck und fügt den in runde Klammern 

gesetzten Ausdruck an der aktuellen Cursorposition in der Authorzeile ein.  
 

1.9  Löschen und Verschieben von Bildschirmzeilen 
  
Um Speicherplatz zu sparen und auch um die Übersichtlichkeit am Bildschirm zu gewährleis-
ten, ist es vorteilhaft, nicht mehr benötigte Bildschirmzeilen entfernen zu können.  
 
Bildschirmzeilen werden gelöscht, indem man sie markiert und dann die Entf-Taste drückt 
(oder den Menübefehl Edit > Delete anwählt oder das Delete-Symbol in der Befehlssymbol-
leiste anklickt).  
 
Mit Hilfe von Edit > Undelete (bzw. der Tastenkombination Strg + z) kann man das letzte 
Löschen rückgängig machen. Anwenden von Edit > Undelete hat zur Folge, dass der zuletzt 
gelöschte Zeilenblock nach der aktuell markierten Bildschirmzeile eingefügt wird (und kann 
daher auch zum Verschieben von Bildschirmzeilen verwendet werden).  
 



Markierte Bildschirmzeilen können außerdem mit Hilfe des Befehls Edit > Cut  (bzw. Ankli-
cken des Cut-Symbols) in die Windows-Zwischenablage übernommen und mit Edit > Paste 
(bzw. Anklicken des Paste-Symbols) nach der aktuell markierten Bildschirmzeile wieder einge-
fügt werden. 
 
Ist der Menüpunkt Options > Renumber Expressions aktiviert, so werden die nach dem Lö-
schen bzw. nach dem Umgruppieren vorhandenen Bildschirmzeilen automatisch neu durch-
nummeriert. 
 

1.10 Einfügen von Textobjekten 
  
Der Menübefehl  Insert > Object (bzw. die Funktionstaste F5) fügt nach der aktuell markier-
ten Bildschirmzeile ein Textfeld ein. Dadurch können Arbeitsblätter gestaltet werden, die neben 
mathematischen Ausdrücken auch erläuternde Texte enthalten. 
 
Durch Aktivieren des Menüpunkts Window > View Toolbars > Formatting Toolbar kann 
man eine Menüleiste einblenden, über die das Layout des Textfeldes verändert werden kann: 
Man kann Schriftart und Schriftgröße festlegen, Fettdruck, Kursivdruck oder Unterstreichen 
anwählen sowie den Text wahlweise linksbündig, rechtsbündig oder zentriert anordnen. 
 
Durch Drücken der Esc-Taste bzw. durch Anklicken einer Bildschirmstelle außerhalb des 
Textfelds mit der linken Maustaste kann man ein aktives Textfeld verlassen und mit der Einga-
be mathematischer Ausdrücke fortsetzen. 
 
Ein Textfeld kann wie jeder mathematische Ausdruck durch Markieren und anschließendes 
Drücken der Entf-Taste gelöscht werden.  
 
Beim Speichern von Arbeitsblättern ist zu beachten, dass eingefügte Textfelder und Graphiken 
nur im Dateityp DfW-File mitgespeichert werden können. Will man in einem mth-File erläu-
ternde Texte mitspeichern, so sind diese in Anführungszeichen gesetzt in der Authorzeile ein-
zugeben. 
 

2. Einführung in die 2D-Graphik von Derive 
 

2.1 Zeichnen von Funktionsgraphen und Kurven 
  
Markiert man im Algebrafenster einen Ausdruck, der genau eine Variable enthält, zum Beispiel  
x²-1, und wählt den Menübefehl Window>New 2D-plot Window an (oder klickt das 2DPlot-
Symbol an), so eröffnet Derive ein 2D-Graphikfenster.  
  
Nach Anwählen des Plot-Befehls im 2D-Graphikfenster, das heißt  

- Anwählen des Menüpunktes Insert > Plot  
- oder Drücken der Funktionstaste F4  



- oder Anklicken des Plot-Symbols in der Symbolleiste 
wird der Graph der Funktion  x → x²-1  gezeichnet. 
  
Durch Anklicken des AlgebraWindow-Symbols oder Drücken der Tastenkombination Strg  
F6 kann man ins Algebrafenster zurückkehren.  
 
Markiert man dort einen neuen Ausdruck, zum Beispiel x², und klickt dann das 2Dplot-Symbol 
an, so wird das zuvor eröffnete 2D-Graphikfenster mit dem Graphen der Funktion x → x²-1 
aktiviert. Anwählen des Plot-Befehls im Graphikfenster bewirkt, dass der Graph der aktuell 
markierten Funktion  x → x² dazugezeichnet wird.  
 
Mit Hilfe der Graphikmenübefehle Edit > Delete Plot und Edit > Delete all Plots kann man 
einzelne oder alle Graphiken löschen.  Einfacher kann man durch Drücken der Entf-Taste bzw. 
Anklicken des Delete-Symbols in der Symbolleiste  die zuletzt gezeichnete Graphik löschen.  
 
Löscht man einen bereits gezeichneten Term im Algebrafenster, so wird dadurch die zugehöri-
ge Graphik nicht gelöscht. Die Graphik bleibt weiterhin nach jedem Aufruf des Graphikfensters 
sichtbar, so lange bis sie im Graphikfenster gelöscht wird. 
  
Der Menübefehl Window ermöglicht die Verwaltung der gleichzeitig verwendeten Fenster. 
 
 
Hinweise: 
  
In einem 2D-Graphikfenster können nur mathematische Ausdrücke folgender Art graphisch 
dargestellt werden:    
 
i)  Ausdrücke der Form u, die nur eine Variable enthalten (z.B. x²-3). In diesem Fall wird der 

Graph der Funktion x → u(x) gezeichnet.   
 
ii)   Gleichungen bzw. Ungleichungen der Form y = u bzw. y < u bzw. y > u, wobei y eine Va-

riable und u ein Ausdruck in genau einer anderen Variablen ist (z.B. y = x²-3 bzw. y < x²-3 
bzw. y > x² - 3). Auch hier wird der Graph der Funktion y = u(x) bzw. der Relation y < 
u(x)  bzw. y > u(x)) gezeichnet. 

 
iii)   Gleichungen bzw. Ungleichungen der Form u = v (bzw. u < v bzw. u > v), wobei u und v 

Ausdrücke in insgesamt maximal zwei Variablen sind (z.B. x² + y² = 4). In diesem Fall 
werden die beiden Variablen in alphabetischer Reihenfolge der x- und der y-Achse zuge-
ordnet, die Variable x aber auf jeden Fall der x-Achse. (Beachten Sie etwa den Unter-
schied zwischen a² + 4b²  = 4 und c² + 4b² = 4). Der Algorithmus zum Zeichnen solcher 
implizit definierter Kurven oder Flächen startet in der linken oberen Ecke des 2D-
Graphikfensters und zeichnet von oben nach unten Spalte für Spalte von links nach rechts. 

 
iv)  Logische Ausdrücke, zusammengesetzt aus Ausdrücken der obigen Art und den Operato-

ren AND, OR bzw. NOT. (z.B. x+y<1 AND x+2y>3)    
 
v) Parameterdarstellungen ebener Kurven  
 



vi)  Listen bestehend aus mindestens drei Ausdrücken der obigen Art (zum Beispiel [x^2-1, 
x^2, x^2+2]), siehe dazu Abschnitt 8.2 Zeichnen von Funktionenscharen 

 
  

2.2 Ändern des Bildschirmausschnitts 
  
Markiert man im Algebrafenster den Ausdruck x²+4, aktiviert dann ein 2D-Graphikfenster und 
wählt dort den Plot-Befehl an, so wird scheinbar überhaupt nichts gezeichnet. Der Grund dafür 
ist, dass der Graph der Funktion x → x²+4 zur Gänze außerhalb des voreingestellten Zeichen-
bereichs liegt. In diesem und in vielen anderen Fällen ist es notwendig, den Bildschirmaus-
schnitt so zu verändern, dass wesentliche Teile des Graphen sichtbar werden. Derive stellt dazu 
die folgenden Möglichkeiten zur Verfügung:  
 

2.2.1 Stauchen und Strecken des Bildschirmausschnitts 
  
Mit Hilfe der Funktionstasten F5 bis F10 kann man den Achsenmaßstab des Bildschirmaus-
schnitts bequem verändern: 
 
F7  bzw.  F8  vergrößert bzw. verkleinert in vertikaler Richtung 
F5 bzw. F6    vergrößert bzw. verkleinert in horizontaler Richtung  
F9  bzw.  F10  vergrößert bzw. verkleinert gleichmäßig in beiden Richtungen 
  
Daneben kann der Bildschirmmaßstab auch mit Hilfe der Graphikmenübefehle 
 Set > Plot Region   und    Set > Plot Range verändert werden. 
 
Mit Set > Aspect Ratio kann ein bestimmtes Achsenverhältnis eingestellt werden. Um zu er-
reichen, dass Kreise wirklich als Kreise dargestellt werden, klickt man im Dialogfeld von Set > 
Aspect Ratio das Reset-Feld und anschließend OK  an.  
  

2.2.2 Bewegen des eingezeichneten Kreuzes 
  
Im 2D-Graphikfenster gibt es ein bewegbares Kreuz, dessen Koordinaten in der Statuszeile bei 
Cross abgelesen werden können. Die Koordinaten dieses Kreuzes können geändert werden: 
  
-  durch Anwählen des Graphikmenübefehls Set > Cross Position und anschließendes Ein-

tippen der gewünschten Koordinaten, 
 
-  durch Anklicken der gewünschten Bilschirmstelle mit der linken Maustaste 
 
-  mit Hilfe der vier Cursortasten ↑↑↑↑, ↓↓↓↓, ←←←← , →→→→ (diese bewegen das Kreuz um ein Pixel nach 

oben, unten, links bzw. rechts), 
 



-  mit Hilfe der Tasten Bild ↑↑↑↑ bzw. Strg ↑↑↑↑, Bild ↓↓↓↓ bzw. Strg ↓↓↓↓, Strg →→→→, Strg  ←←←← (diese be-
wegen das Kreuz um einen halben Gitterpunktsabstand nach oben, unten, rechts bzw. 
links) 

  

2.2.3 Verschieben des Bildschirmausschnitts  
  
Ein Verschieben des Bildschirmausschnitts ist mit Hilfe der Symbole Center on Origin  bzw. 
Center on Cross oder mit Hilfe des Folgemodus möglich:  
  
- Anklicken des Symbols Center on Cross bewirkt, dass der Bildschirmausschnitt so transliert 
wird, dass die momentanen Koordinaten des Kreuzes den neuen Bildschirmmittelpunkt bilden. 
Man kann daher den Bildschirmausschnitt bequem verschieben, indem man zuerst das Kreuz an 
eine geeignete Stelle bewegt und dann dieses Symbol anklickt.  
 
- Anklicken des Symbols Center on Origin bewirkt, dass der Bildschirmausschnitt so trans-
liert wird, dass der Koordinatenursprung im Bildschirmmittelpunkt liegt. 
  
- Im Folgemodus folgt der Bildschirmausschnitt dem Kreuz, wenn dieses über den Bildschirm-
rand hinaus bewegt wird. Der Folgemodus wird durch Anklicken des Menüpunktes Options > 
Follow Cross ein- bzw. wieder ausgeschaltet. 
   

2.2.4 Automatische Skalierung in vertikaler Richtung 
  
Sehr hilfreich beim Zeichnen von Graphen ist die Möglichkeit, durch Anklicken des Menü-
punkts  Options > Autoscale New Plots die automatische Skalierung der y-Achse einzuschal-
ten. In diesem Modus versucht das Programm, für die y-Achse einen optimalen Maßstab und 
einen geeigneten Ausschnitt zu finden.  
  

2.2.5 Direkte Eingabe der Bildschirmränder 
  
Mit Hilfe des Symbols Set Range with Box ist es möglich, die gewünschten Ränder des Bild-
schirmausschnittes direkt einzugeben: Nach Anklicken dieses Symbols verwandelt sich der 
Mauszeiger in ein großes Kreuz. Dieses Kreuz bewegt man an die gewünschte linke obere E-
cke des Bildschirmausschnitts, drückt dort die linke Maustaste und bewegt die Maus mit ge-
drückter linker Maustaste zur gewünschten rechten unteren Ecke. Loslassen der linken Maus-
taste bewirkt, dass ein Dialogfeld mit den Begrenzungskoordinaten des markierten Bildschi-
mausschnitts eingeblendet wird. Durch Drücken der Enter-Taste werden diese Ränder bestä-
tigt, durch Eintippen anderer Werte in diesem Dialogfeld kann man die Ränder entsprechend 
verändern.  
 

2.2.6 Rückkehr zu den ursprünglichen Bildschirmeinstellungen 
  



Oft erscheint es wünschenswert, das Graphikfenster in den ursprünglichen Zustand zurückzu-
versetzen. Am einfachsten erreicht man das, indem man im Dialogfeld des Menüpunktes Set > 
Plot Region oder des Menüpunktes Set Plot > Range das Reset-Feld anklickt und anschlie-
ßend mit OK  bestätigt.   
  
Dieser Befehl bewirkt, dass die Einstellungen für den Maßstab und die Koordinatenachsen auf 
die Werte der Initialisierungsdatei zurückgesetzt werden.  
  
  

2.3 Untersuchen von Graphen mit dem Spurmodus 
  
Mit Hilfe der Funktionstaste F3  (oder des Menübefehls Options > Trace Plots) kann der so-
genannte Spurmodus ein- und ausgeschaltet werden. In diesem Modus bewegt sich das einge-
zeichnete Kreuz nur entlang von Funktionsgraphen. Dadurch ist es möglich, Koordinaten ein-
zelner Punkte eines Graphen möglichst genau abzulesen.  
  
Schaltet man den Spurmodus ein, so springt das Kreuz auf einen Funktionsgraphen und nimmt 
die Form eines kleinen Quadrats an. Die Cursortasten →→→→ und ←←←← bewegen dieses Quadrat ent-
lang des Graphen um ein Pixel nach rechts bzw. nach links, die Tastenkombinationen Strg  →→→→ 
und Strg  ←←←← um einen halben Gitterpunktabstand nach rechts oder links. Sind mehrere Funkti-
onsgraphen vorhanden, so kann man mit den Cursortasten  ↑↑↑↑   und  ↓↓↓↓ das Quadrat auf einen 
anderen Graphen bewegen.  
  
Auf implizite Graphiken und auf Punktlisten (siehe Abschnitt 8.1 Zeichnen von Punktlisten und 
Streckenzügen) ist der Spurmodus nicht anwendbar. 
 
  

2.4 Weitere Einstellmöglichkeiten für 2D-Graphikfenster 
  

2.4.1 Die Koordinatenachsen 
  
Mit Hilfe des Graphikmenübefehls Options > Display > Axes kann man verschiedene Ände-
rungen an der Darstellung der Koordinatenachsen vornehmen: 
 
Lines: On/ Off 
Durch Anwählen von Off  erreicht man, dass die Koordinatenachsen ausgeblendet werden.  
Labels: On/ Off 
Hier kann man entscheiden, ob die Markierungen der Einheiten der Koordinatenachsen be-
schriftet werden. 
Titles: Horizontal axis/ Vertical axis 
Hier kann man Bezeichnungen der Koordinatenachsen eingeben. Unabhängig von der Vari-
ablenbezeichnung in der Funktionsgleichung wird im Graphikfenster diese Achsenbeschriftung 
verwendet.  
 



Außerdem kann jeweils die Farbe, in der die Achsen, die Einheiten bzw. die Achsentitel darge-
stellt werden, gewählt werden.   
 

2.4.2 Das Kreuz und die Gitterlinien 
 
Mit Hilfe des Graphikmenübefehls Options > Display > Cross kann die Farbe des sichtbaren 
Kreuzes gewählt bzw. das Kreuz ausgeblendet werden. 
 
Der Graphikmenübefehl Options > Display > Grids ermöglicht es, die Anzahl der Intervalle 
zu wählen, in die die x-Achse bzw. y-Achse unterteilt wird. Außerdem können wahlweise Git-
terpunkte oder Gitterlinien dargestellt sowie deren Farbe festgelegt werden.     
 

2.4.3 Auswahl der Zeichenfarbe 
  
Mit Hilfe der Graphikmenübefehle Options > Display > Plot Color bzw. Options > Display 
> Background Color kann man die Farbe für den nächsten Funktionsgraphen bzw. die Hinter-
grundfarbe verändern.  
 
Ist Options > Change Plot Colors aktiviert, so ändert Derive beim Zeichnen mehrerer Gra-
phen von Graph zu Graph automatisch die Zeichenfarbe.  
  

2.4.4 Kartesische Koordinaten oder Polarkoordinaten 
 
Mit Hilfe des Menübefehls Set > Coordinate System kann man wahlweise kartesische Koor-
dinaten oder Polarkoordinaten einstellen. 
 
 

2.5 Beschriften von Graphiken 
 
Anwählen des Menübefehls Insert > Annotation bzw. Drücken der Funktionstaste F12 er-
möglicht es, an der aktuellen Kreuzposition ein Textfeld einzufügen. Im Dialogfeld ist der ge-
wünschte Text einzutippen; außerdem können Schriftart, Schriftgröße und Farbe gewählt wer-
den. 
 
Um den Inhalt oder das Layout eines eingefügten Textfeldes zu verändern, klickt man dieses 
mit der Maus an und wählt den Menüpunkt Edit > Annotation an. Außerdem kann man die 
Position eines Textfeldes durch Anklicken des Textfelds mit der linken Maustaste und an-
schließendes Ziehen der Maus mit gedrückter linker Maustaste verändern. 
 
Mit Edit > Delete Annotation kann man ein einzelnes zuvor mit der Maus markiertes Text-
feld, mit Edit > Delete All Annotations alle vorhandenen Textfelder löschen.  
   
 



2.6 Einbetten von Graphiken ins Algebrafenster 
 
Der Menübefehl File > Embed bettet ein Bild des Graphikfensters im zugehörigen Algebra-
fenster ein. 
 
Durch Anklicken und Ziehen des Randes mit der Maus kann man die Größe dieses eingebette-
ten Bildes verändern.  
 
Ein Doppelklick auf das eingebettete Bild aktiviert das zugehörige Graphikfenster und ermög-
licht es, dort Änderungen vorzunehmen (zum Beispiel das Achsenverhältnis mit Set > Aspect 
Ratio zu korrigieren). Anschließend können die Änderungen mit dem Graphikmenübefehl File 
> Update ins eingebettete Bild übernommen werden.   
 
Außerdem besteht die Möglichkeit, rechteckige Ausschnitte des Graphikfensters mit Hilfe von 
Edit>Mark and Copy in die Windows-Zwischenablage zu kopieren, und von dort mit E-
dit>Paste in ein Algebrafenster (oder auch in ein Word-Fenster) einzufügen. 
 

3. Veränderung von Voreinstellungen im Algebrafenster 
  

3.1 Zahldarstellung und Rechengenauigkeit 
  
Mit dem Menübefehl Declare>SimplificationSettings>Precision kann die Rechengenauigkeit 
eingestellt werden. Zur Auswahl stehten die Modi Exact, Approximate und Mixed, daneben 
kann im Menüfeld Digits die Anzahl der signifikanten Stellen festgelegt werden. 
  
Beim Starten von Derive ist der Exact-Modus voreingestellt, in dem alle numerischen Operati-
onen in einer rationalen Arithmetik durchgeführt werden. Rationale Zahlen werden hier als 
gekürzte Brüche dargestellt, irrationale Zahlen werden nicht näherungsweise berechnet, son-
dern verbleiben in symbolischer Schreibweise. Die angegebene Stellengenauigkeit im Digits-
Feld des Untermenüs hat im exakten Rechenmodus nur für das Ermitteln von Näherungswerten 
mit dem Approx-Symbol Relevanz.   
  
Im Approximate-Modus werden irrationale Zahlen und lange rationale Zahlen auf die momen-
tan gewählte Stellengenauigkeit gerundet. Den Näherungsmodus wird man dann verwenden, 
wenn man Rechenzeit und Speicherplatz sparen will und Rundungsfehler in Kauf genommen 
werden können. 
  
Im Mixed-Modus werden Operationen mit rationalen Zahlen exakt durchgeführt, irrationale 
Zahlen dagegen werden auf die gewählte Stellengenauigkeit angenähert.  
  
Beispiel1:  
Eingabe des Ausdrucks  √√√√(4+2√√√√3)  und Vereinfachen mit  dem Simplify-Symbol liefert im ex-
akten Rechenmodus das Ergebnis √√√√3 + 1, im Approximate-Modus und im Mixed-Modus das 
Ergebnis 2.732050807. Im exakten Rechenmodus wird also wohl der geschachtelte Wurzel-



ausdruck durch Umformungen vereinfacht, im Ergebnis bleibt aber √3 in symbolischer 
Schreibweise.  
 
Beispiel2:  
Eingabe des Ausdrucks  (5/8)^99  und Vereinfachen mit dem Simplify-Symbol liefert im exak-
ten Rechenmodus das exakte Ergebnis als Bruchzahl, im Approximate-Modus erhält man einen 
Näherungswert in Dezimalschreibweise. 
 
  
Diese Beispiele zeigen, dass die Wahl des Rechenmodus automatisch auch die Darstellungs-
form des Ergebnisses beeinflusst. So zieht der Exact-Modus rationale, der Approximate-
Modus wissenschaftliche und der Mixed-Modus gemischte Darstellung nach sich. Auch die 
Anzahl der ausgegebenen Dezimalstellen wird automatisch der eingestellten Rechengenauigkeit 
angepasst. Dadurch wird die Wahl der Notation des Ergebnisses meistens überflüssig.  
  
Will man trotzdem die Form der Ausgabe unabhängig vom Rechenmodus festlegen, so kann 
man dies mit dem Menübefehl Declare>Output Settings: Notation tun. Zur Auswahl steht 
hier Decimal, Mixed, Rational und Scientific. Da der  Precision Mode-Befehl automatisch 
eine bestimmte Ausgabeform nach sich zieht, kann der Notation-Befehl nur wirksam werden, 
wenn er erst nach der Wahl des Rechenmodus aufgerufen wird. 
 
 
 

3.2 Basis des Zahlensystems 
  
Mit Hilfe des Menübefehls Declare>Input Settings: Radix und Declare>Output Settings: 
Radix kann die Basis des Zahlensystems der in der Authorzeile eingetippten bzw. der im Al-
gebrafenster ausgegebenen Zahlen gewählt werden. Voreingestellt ist jeweils das Dezimalsys-
tem. 
 
Möglich sind die Basen 2 bis 36. Bei Basen größer als zehn werden die Buchstaben A bis Z zur 
Darstellung der "Ziffern" 10 bis 35 verwendet. Um bei der Eingabe Verwechslungen mit Vari-
ablen zu vermeiden, müssen Zahlen, die mit einem Buchstaben beginnen mit einer vorangestell-
ten Null geschrieben werden. 
 
Beispiel: 
Belässt man die Eingabebasis 10 und setzt die Ausgabebasis auf 16, so kann man bequem Zah-
len aus dem Dezimalsystem ins Hexadezimalsystem umwandeln: 
Die in der Authorzeile eingetippten Dezimalzahlen 12, 29, 3645, 24.5,... werden im Algebra-
fenster in Hexadezimalschreibweise als 0C, 1D, 0E3D, 18.8,... dargestellt. 
 
 

3.3 Variablendarstellung 
  



3.3.1 Character-Modus und Word-Modus 
  
- Beim Einschalten von Derive ist der sogenannte Character-Modus voreingestellt, in dem 
Variablen, die nicht mit   :=  oder mit dem Declare > Variable Value-Befehl  definiert worden 
sind, nur mit einem einzigen Buchstaben bezeichnet werden dürfen (Dabei sind auch griechi-
sche Buchstaben möglich, auch Variablennamen bestehend aus einem Buchstaben und folgen-
den Unterstreichungszeichen (z.B. x_) sind zulässig). Beim Eingeben von Ausdrücken im Cha-
racter-Modus müssen zwei Variablenbezeichnungen nicht durch einen Abstand getrennt wer-
den. 
  
- Daneben gibt es den Word -Modus, in dem Variablenbezeichnungen aus beliebig vielen Buch-
staben, Ziffern oder Unterstreichungszeichen zusammengesetzt werden dürfen (nur das erste 
Zeichen muss ein Buchstabe sein!). Der Vorteil dieses Modus besteht darin, dass man Variab-
len aussagekräftige Namen geben kann. Nachteilig ist, dass man hier beim Eingeben von Aus-
drücken sorgfältig darauf achten muss, zwei Variablen durch einen Abstand, durch einen Ope-
rator oder durch runde Klammern zu trennen.  
  
Mit dem Menübefehl Declare>Input Settings>Input Mode: Character/Word kann man 
zwischen Character-Modus und Word-Modus umschalten. 
  
  

3.3.2 Groß- und Kleinschreibung von Variablen 
  
Nach Anwählen des Menübefehls  Declare>Input Settings erscheint ein Untermenü, das unter 
anderem den Menüteil Case Sensitivity: Insensitive/ Sensitive enthält. Beim Starten von De-
rive ist üblicherweise Insensitive voreingestellt. 
  
- Insensitive bedeutet, dass bei der Eingabe von Ausdrücken zwischen Groß- und Kleinschrei-
bung nicht unterschieden werden muss. Unabhängig von der Schreibweise in der Authorzeile 
stellt Derive im Algebrafenster Variablennamen immer in Kleinbuchstaben und Namen von 
vordefinierten Standardfunktionen immer in Großbuchstaben dar. Namen von userdefinierten 
Funktionen werden in jener Schreibweise ausgegeben, in der sie erstmalig definiert worden 
sind.  
  
- Im Sensitive-Modus kann die Groß- bzw. Kleinschreibung zur Unterscheidung von Variab-
len- und Funktionsnamen verwendet werden. Hier bezeichnen, zum Beispiel, r und R verschie-
dene Größen. Zu beachten ist, dass in diesem Modus die Namen der vordefinierten Standard-
Funktionen (wie zum Beispiel SIN, COS,...) unbedingt in Großbuchstaben eingegeben werden 
müssen. 
  

3.4 Bogenmaß und Gradmaß 
 
Mit Hilfe des Menübefehls Declare>Simplification Settings>Angular unit  kann zwischen 
Bogenmaß (Radian) und Gradmaß (Degree) umgestellt werden. Voreingestellt ist Radian. 
 



Bei der Verwendung trigonometrischer Funktionen ist darauf zu achten, ob Bogenmaß oder 
Gradmaß aktuell ist: So beschreibt, zum Beispiel, der Ausdruck SIN(90) im Bogenmaßmodus 
den Sinuswert des Winkels 90 rad, und auch die inversen trigonometrischen Funktionen liefern 
als Ergebnis den Winkel in rad. 
 
Mit Hilfe der vordefinierten Konstante DEG (eingeben als deg oder als °) kann man Gradmaß 
in Bogenmaß umwandeln. DEG ist in der Bogenmaßeinstellung mit dem Wert π/180 belegt. 
So beschreibt, zum Beispiel, der Ausdruck SIN(90°) im Bogenmaßmodus den Sinuswert des 
Winkels 90°, und ASIN(0.5)/° das Gradmaß des Winkels, dessen Arcussinuswert gleich 0.5 ist.   
(Zu beachten: Im Gradmaßmodus hat die Konstante DEG den Wert 1) 
 
 

3.5 Zurück zu den ursprünglichen Einstellungen 
 
Durch Anwählen des Menübefehls Declare > Reset All Settings werden gleichzeitig alle mit 
den Menübefehlen 
 
Declare > Input Settings, 
Declare > Output Settings und 
Declare > Simplification Settings 
 
durchgeführten Änderungen der Zustandsvariablenbelegungen wieder rückgängig gemacht und 
auf die ursprünglichen Werte zurück gesetzt.  
 

3.6 Layout des Algebrafensters 
 
Mit Hilfe des Menübefehls Options>Display kann das Layout des Algebrafensters verändert 
werden. Im zugehörigen Untermenü stehen die folgenden Befehle zur Verfügung: 
 
Alignment of New Objects Bildschirmzeilen, eingebettete Graphiken, Textobjekte 

und OLE-Objekte können wahlweise linksbündig, zent-
riert oder rechtsbündig angeordnet werden. 

  
Font of All Expressions Größe und Farbe der Bildschirmausdrücke kann gewählt 

werden. 
  
Font of New Text Objects Schriftart, Farbe und Größe der neueinzugebenden 

Textobjekte kann gewählt werden. 
  
Background Color Die Hintergrundfarbe kann gewählt werden.  
 
 

3.7 Verwaltung mehrerer geöffneter Fenster 
 



Eröffnen von Fenstern: 
Beim Starten von Derive wird gleichzeitig ein Algebrafenster eröffnet, das in der Titelleiste die 
Bezeichnung Algebra 1 trägt. Mit dem Menübefehl File>New  können weitere Algebrafenster 
geöffnet werden; diese erhalten zur Unterscheidung die Bezeichnungen Algebra 2, Algebra 3, 
usw. 
 
Derive kennt daneben noch 2D- und 3D-Graphikfenster. Graphikfenster können mit Hilfe der 
Menübefehle Window>New 2D-plot Window bzw. Window>New 3D-plot Window eröff-
net werden. Jedes Graphikfenster ist einem bestimmten Algebrafenster zugeordnet. So werden, 
zum Beispiel, die zum Fenster Algebra 3 gehörenden 2D-Graphikfenster der Reihe nach mit 
2Dplot 3:1, 2Dplot 3:2, 2Dplot 3:3, usw. bezeichnet. 
    
Schließen von Fenstern: 
Fenster können durch Anklicken des Schließsymbols (ganz rechts in der Menüleiste des jewei-
ligen Fensters) oder mit Hilfe des Menübefehls File>Close geschlossen werden. 
Graphikfenster können einzeln geschlossen werden. Beim Schließen eines Algebrafensters 
werden gleichzeitig auch alle diesem Fenster zugeordneten Graphikfenster geschlossen. 
 
Anordnen der Fenster auf dem Bildschirm: 
Mit Hilfe der Menübefehle 
Window>Cascade,  Window>Tile Horizontally ,  Window>Tile Vertically  
kann man die geöffneten Fenster hintereinander gefächert, übereinander bzw. nebeneinander 
anordnen. 
 
Aktivieren eines Fensters: 
Das jeweils aktive Fenster ist an der blauen Färbung seiner Titelzeile erkennbar. 
Die einzelnen eröffneten Fenster können auf verschiedene Arten aktiviert werden: 

- Klickt man mit der Maus in ein Fenster, so wird dieses aktiviert. (Da Mausklicks in einem 
Algebrafenster die Markierung der jeweiligen Bildschirmzeile und in einem 
2DGraphikfenster die Veränderung der Kreuzposition zur Folge haben, sollte man am bes-
ten die Titelleiste anklicken)  

- Im Menüpunkt Window findet man eine Liste aller eröffneten Fenster. Ein bestimmtes 
Fenster kann durch Anklicken seines Fensternamens in dieser Liste aktiviert werden.  

- Die Tastenkombination Strg + F6 schaltet zum jeweils letzten aktiven Fenster um. Durch 
wiederholtes Drücken der Funktionstaste F6 bei gleichzeitig gedrückter Strg-Taste kann 
man daher jedes gewünschte Fenster erreichen. (Ist die Authorzeile aktiv, so muss man sie 
vor der Anwendung von Strg + F6 durch Drücken der Esc-Taste deaktivieren.) 

- Durch Anklicken des Algebrafenster-Symbols kann man von einem aktiven Graphikfenster 
aus das zugehörige Algebrafenster aktivieren. 

- Durch Anklicken des 2DGraphik- bzw. 3DGraphik-Symbols und kann man von einem ak-
tiven Algebrafenster aus das zuletzt aktivierte der zugeordneten 2D- bzw. 3D-Fenster akti-
vieren.    

  
 



4. Lösen von Gleichungen und Ungleichungen 
  
  

4.1 Lösen von Gleichungen 
 
Mit Hilfe des Menübefehls Solve > Expressions können viele Gleichungen, Ungleichungen, 
Gleichungssysteme und Ungleichungssysteme auf Knopfdruck gelöst werden. 
 
Will man, zum Beispiel, die Lösungen der Gleichung x4 - 4 = 0 ermitteln, so markiert man im 
Algebrafenster die Gleichung x4 - 4 = 0 (oder einfach den Term x4 - 4) und wählt den Menü-
punkt Solve > Expressions  an (oder klickt stattdessen das Solve-Symbol in der Befehlssym-
bolleiste an). Daraufhin erscheint das folgende Dialogfeld: 
 

  
 
 

- Enthält der markierte Term mehrere Variablen, so kann man im Auswahlfeld Solution Va-
riables festlegen, welche Variable explizit ausgedrückt werden soll. 

- Im Auswahlfeld Solution Method kann man entscheiden, ob die Gleichung mit algebrai-
schen oder numerischen Methoden gelöst werden soll.  

- Hat man die algebraische Lösungsmethode gewählt, so kann man im Auswahlfeld Solution 
Domain festlegen, ob alle komplexen Lösungen oder nur alle reellen Lösungen ermittelt 
werden sollen. 

- Die numerische Lösungsmethode erlaubt im Auswahlfeld Solution Domain als dritte Vari-
ante außerdem die Angabe eines Intervalls, in dem eine Näherungslösung gesucht werden 
soll.       

- Verlässt man das obige Auswahlfeld durch Anklicken des Solve-Feldes, so werden die er-
mittelten Lösungen als logischer Ausdruck dargestellt.   

 
Im obigen Beispiel erhält man bei Auswahl von 
 
Algebraically und Complex x = - √2·î ∨ x = √2·î ∨ x = - √2 ∨ x = √2 
Algebraically und Real x = - √2 ∨ x = √2 
Numerically und Complex x = - 1.414213562·î ∨ x = 1.414213562·î ∨ x = -



1.414213562 ∨ x = 1.414213562 
Numerically und Real x = -1.414213562 ∨ x = 1.414213562 
Numerically und Bounds x = 1.414213553 (In diesem Fall wird nur eine einzige Nä-

herungslösung ermittelt) 
 
 
Statt des Menübefehls Solve > Expressions kann auch die vordefinierte SOLVE-Funktion 
oder die SOLUTIONS-Funktion zum Lösen von Gleichungen verwendet werden. Allgemein 
lautet die Syntax dieser Funktionen folgendermaßen: 
 
SOLVE(u, x)   ermittelt alle komplexen Lösungen der Gleichung  u=0 nach 

der Variablen x  
SOLVE(u, x, Real)   ermittelt alle reellen Lösungen der Gleichung  u=0 nach der 

Variablen x 
SOLVE(u = v, x)   ermittelt alle komplexen Lösungen der Gleichung  u=v nach x 
SOLVE(u = v, x, Real)  ermittelt alle reellen Lösungen der Gleichung  u=v nach x 
NSOLVE(u, x) bzw. 
NSOLVE(u =v, x)   

ermittelt mit numerischen Methoden komplexe Näherungslö-
sungen der Gleichung u = 0 bzw. u = v 

NSOLVE(u, x, Real) bzw. 
NSOLVE(u = v, x, Real)    

ermittelt mit numerischen Methoden Näherungen der reellen 
Lösungen der Gleichung u = 0 bzw. u = v 

NSOLVE(u = v, x, a, b)   sucht eine reelle Näherungslösung der  Gleichung u=v nach x 
im Intervall [a; b] 

 
Ersetzt man in den obigen Befehlen das Schlüsselwort SOLVE durch SOLUTIONS bzw. 
NSOLVE durch NSOLUTIONS, so werden die ermittelten Lösungen nicht als logischer Aus-
druck, sondern in Listenschreibweise ausgegeben. 
 
Beispiel:  
- Gibt man im Algebrafenster den Ausdruck SOLVE(x²-x-6,x) ein und vereinfacht mit 

Simplify, so erhält man die Lösungen  der Gleichung  x²-x-6 = 0 in der Schreibweise  x = -2 
∨∨∨∨ x = 3.  

- Setzt man die Gleichung im SOLVE-Befehl in eckige Klammern (zum Beispiel SOL-
VE([x²-x-6], x)), so ergibt Vereinfachen dieses Ausdrucks mit Simplify die Lösungen der 
Gleichung in der Schreibweise [x = -2, x = 3].  

- Vereinfachen des Ausdrucks SOLUTIONS(x²-x-6, x) liefert die Lösungen der Gleichung 
in der Schreibweise  [-2, 3]. 

  
 
Findet Derive bei einer Gleichung keine Lösung, so gibt die SOLUTIONS-Funktion als Ergeb-
nis den leeren Vektor  [ ] und die SOLVE-Funktion den Ausdruck false aus. 
Ist eine Gleichung im gewählten Lösungsbereich allgemeingültig, so liefert die SOLUTIONS-
Funktion als Ergebnis einen Vektor der Form [@n], wobei n eine natürliche Zahl ist, und die 
SOLVE-Funktion den Ausdruck true. 
 
 



4.2 Schrittweises Lösen von Gleichungen 
  
Daneben ist es auch möglich, Gleichungen Schritt für Schritt durch Anwenden von Äquiva-
lenzumformungen zu vereinfachen.  
  
Beispiel1:  
Geben Sie die Gleichung  3x-4 = 5+8x  ins Algebrafenster ein.  
- Durch Drücken  der Funktionstaste F4 wird die Gleichung in die Authorzeile geholt und in 
Klammern gesetzt.  
- Nach Eintippen von  -8x  und Drücken der Enter-Taste erscheint in der nächsten Zeile des 
Algebrafensters der Ausdruck  (3x-4 = 5+8x)-8x.  
- Anklicken des Simplify -Symbols bewirkt nun, dass die Äquivalenzumformung "auf beiden 
Seiten der Gleichung minus 8x" ausgeführt wird, und man erhält den Ausdruck  -5x-4 = 5.  
- Analog dazu kann man nun auf beiden Seiten der Gleichung 4 addieren und dann noch beide 
Seiten der Gleichung durch -5 dividieren, und man  erhält so schließlich die Lösung  x = -9/5.  
 
Das entsprechende Derive-Bildschirmprotokoll sieht folgendermaßen aus: 
  
1:  3 x - 4 = 5 + 8 x 
  
2:  (3 x - 4 = 5 + 8 x) - 8 x 
  
3:  - 5 x - 4 = 5 
  
4:  (- 5 x - 4 = 5) + 4 
  
5:  - 5 x = 9 
  

6:  
5

95

−
=− x

 

 
7:  x = - 9/5  
                
  
Beispiel2: 
Geben Sie die Gleichung  EXP(x+3) = 5 ins Algebrafenster ein. 
- Nach Eintippen von  LN  in der Authorzeile und Drücken der Funktionstaste F4 und der En-
ter-Taste erscheint in der nächsten Zeile des Algebrafensters der Ausdruck  LN(EXP(x+3)=5). 
- Anwenden des Simplify -Befehls bewirkt nun, dass auf beiden Seiten der Gleichung logarith-
miert wird, und man erhält  x+3 = LN(5). 
- Subtrahiert man noch auf beiden Seiten der Gleichung die Zahl 3, so erhält man die Lösung  x 
= LN(5)-3.  
  
 

4.3 Lösen von Gleichungssystemen 
  



Systeme bestehend aus einfachen Polynomgleichungen können mit Derive auf Knopfdruck 
gelöst werden. Dazu gibt man die einzelnen Gleichungen des Systems  

- entweder durch Beistriche getrennt und in zwei eckige Klammern eingeschlossen  

- oder fortlaufend durch AND getrennt 
in der Authorzeile ein und ruft dann den Menübefehl Solve > Expression auf bzw. klickt das 
Solve-Symbol an. 
  
Beispiele: 
- Markieren des Gleichungssystems  [2x + 3y = 7, 4x - 7y = 1] und Anklicken des Solve-

Symbols führt auf  die Lösung  [x=2 ∧∧∧∧ y=1]. 

- Markieren des Gleichungssystems  2x + 3y = 7 AND 4x - 7y = 1 und Anklicken des Solve-
Symbols führt auf  die Lösung  x=2 ∧∧∧∧ y=1. 

- Markieren des Gleichungssystems [x² + y² = 65, x - 5y = -13] und Anklicken des Solve-
Symbols führt auf  die Lösungen  [x=7 ∧∧∧∧ y=4, x=-8 ∧∧∧∧ y=1]. 

- Markieren des Gleichungssystems  x² + y² = 65 AND x - 5y = -13  und Anklicken des Sol-
ve-Symbols führt auf  die Lösungen  (x=7 ∧∧∧∧ y=4) ∨∨∨∨ (x=-8 ∧∧∧∧ y=1). 

 
Zu beachten ist, dass bei den obigen Beispielen im Solve-Auswahlfeld  

- sowohl x als auch y als Lösungsvariable markiert werden müssen  
- und dass als Lösungsmethode Algebraically ausgewählt werden muss. 

 
 
Statt des Menübefehls Solve kann man auch die vordefinierte SOLVE-Funktion oder die SO-
LUTIONS -Funktion zum Lösen von Gleichungssystemen verwenden: 
 
SOLVE([u 1 = v1, u2 = v2, ..., un = vn], [x1, x2, ..., xn])  bzw. 
SOLVE(u1 = v1 AND u2 = v2 AND ... AND un = vn, [x1, x2, ..., xn]) bzw. 
SOLUTIONS([u 1 = v1, u2 = v2, ..., un= vn], [x1, x2, ..., xn]) bzw. 
SOLUTIONS(u1 = v1 AND u2 = v2 AND ... AND un = vn,[x1, x2, ..., xn]) 
löst das Gleichungssystem u1=v1, u2=v2,...,un = vn  nach den Variablen  x1, x2,...,xn. 
 
Der Unterschied zwischen den beiden Funktionen besteht wieder darin, dass die SOLVE-
Funktion die Lösungen als logischen Ausdruck unter Verwendung von ∧ und ∨ darstellt, wäh-
rend die SOLUTIONS-Funktion eine Liste der Lösungen liefert.   
 
!!!! Die Funktionen NSOLVE und NSOLUTIONS sind auf Gleichungssys-
teme nicht anwendbar  !!!!  
 
 

4.4 Lösen von Ungleichungen und Ungleichungssystemen 
 



Der in Abschnitt 4.1 Lösen von Gleichungen beschriebene Menübefehl Solve > Expressions 
und die dazu äquivalente SOLVE-Funktion sind auch auf Ungleichungen und Ungleichungs-
systeme anwendbar. 
 
 
Beispiele: 
- Markieren der Ungleichung 2x + 1 < 5  und Anklicken des Solve-Symbols führt auf die 

Lösung  x < 2 
- Markieren des Ungleichungssystems  2x + 1 < 3 OR 3x - 1 > 11 und Anklicken des Solve-

Symbols führt auf die Lösung  x < 1 ∨∨∨∨ x > 4 
- Markieren des Ausdrucks SOLVE(3x+5 > 29, x) und Anklicken des Simplify-Symbols 

ergibt die Lösung x > 8. 
- Markieren des Ausdrucks SOLVE(2x+1 < 5 ∨∨∨∨ 2x+3 > 8, x) und Anklicken des Simplify-

Symbols ergibt die Lösung  x < 2 ∨∨∨∨ x > 5/2. 
 
!!!! Die Funktionen NSOLVE und NSOLUTIONS sind auf Ungleichungen 
und Ungleichungssysteme nicht anwendbar  !!!!  
 

5. Grenzwerte, Ableitungen und Integrale 
  

5.1 Differenzieren 
  
Zum symbolischen Differenzieren von Funktionen gibt es  

 
- den Menübefehl Calculus>Differentiate 
- das Ableitungs-Symbol in der Befehlsymbolleiste   
- und die vordefinierte DIF -Funktion 
  . 

  
Beispiel: 
- Um den Ausdruck  a⋅⋅⋅⋅x³  nach x zu differenzieren, markiert man den Ausdruck im Algebra-

fenster und ruft den Menübefehl Calculus>Differentiate auf (oder klickt stattdessen das 
Ableitungssymbol in der Symbolleiste an).  

- Im daraufhin erscheinenden Dialogfeld ist die Ordnung der Ableitung und die Variable, 
nach der differenziert werden soll anzugeben.  

- Verlässt man das Dialogfeld durch Anklicken von OK , so wird die Ableitung im Algebra-
fenster  in der Form d/dx(a⋅⋅⋅⋅x³) dargestellt (Dieser Ausdruck kann mit dem Simplify-
Symbol zu 3⋅⋅⋅⋅a⋅⋅⋅⋅x² vereinfacht werden). Klickt man im Dialogfeld Simplify  an, so erhält man 
sofort die Darstellung 3⋅⋅⋅⋅a⋅⋅⋅⋅x². 

 
 
Man könnte die oben gesuchte Ableitung auch durch Eingabe des Ausdrucks DIF(a⋅⋅⋅⋅x³, x) in 
der Authorzeile und anschließendes Vereinfachen mit dem Simplify-Symbol ermitteln. 



 
Die Syntax der vordefinierten DIF -Funktion lautet: 
 
DIF(u,x)     liefert die erste Ableitung des Ausdrucks u nach der Variablen x. 
DIF(u,x,n)   liefert die n-te Ableitung des Ausdrucks u nach der Variablen x. 
  
 

5.2 Integrieren 
  
Zum symbolischen Integrieren von Funktionen gibt es 
 

- den Menübefehl Calculus>Integrate, 
- das Integral-Symbol in der Befehlsymbolleiste   
- und die vordefinierte INT -Funktion 

  
Beispiel: 
- Um eine Stammfunktion von a⋅⋅⋅⋅x² bezüglich x zu ermitteln, markiert man den Ausdruck im 

Algebrafenster und ruft den Menübefehl Calculus>Integrate auf (oder klickt das Integral-
Symbol in der Befehlsymbolleiste an).  

- Im daraufhin erscheinenden Dialogfeld ist die Integrationsvariable anzugeben und zu ent-
scheiden, ob ein bestimmtes oder unbestimmtes Integral ermittelt werden soll. Bei bestimm-
ten Integralen sind außerdem die Integrationsgrenzen gefragt, bei unbestimmten Integralen 
kann man den Wert der Integrationskonstanten festlegen.  

- Verlässt man das Dialogfeld durch Anklicken von OK , so wird die Stammfunktion bzw. 
das bestimmte Integral im Algebrafenster mit Integralzeichen dargestellt. Klickt man im Di-
alogfeld Simplify  an, so versucht Derive, einen Ausdruck in geschlossener Form zu finden, 
dessen Ableitung den Integranden ergibt. In diesem Beispiel erhält man nach Vereinfachen 
mit Simplify  den Ausdruck   a.x³/3. 

 
 
Man könnte die oben gesuchte Stammfunktion auch durch Eingabe des Ausdrucks INT(a ⋅⋅⋅⋅x², 
x) in der Authorzeile und anschließendes Vereinfachen mit Simplify ermitteln. 
 
Die Syntax der vordefinierten INT -Funktion lautet: 
 
INT(u, x)    liefert die Stammfunktion des Ausdrucks u bezüglich der Variable x. 
INT(u, x, a, b) liefert das bestimmte Integral des Ausdrucks u bezüglich der Variable x 

mit der unteren Grenze a und der oberen Grenze b. 
DIF(u, x, -n)   liefert die n-te Antiderivierte des Ausdrucks u bezüglich der Variable x. 
  
Hinweise: 
- Derive setzt leistungsfähige Techniken ein, um die Stammfunktion einer großen Klasse von 
Funktionen zu berechnen. Es kann aber vorkommen, dass für eine Stammfunktion keine ge-
schlossenen Darstellung mit den in Derive vordefinierten Funktionen und Operatoren existiert. 



Kommen in einem Ergebnis noch Integralzeichen vor, so existiert entweder die Stammfunktion 
nicht oder Derive kann sie nicht vollständig bestimmen.  
   
-Im exakten Rechenmodus ermittelt Derive bestimmte Integrale, indem eine Stammfunktion für 
den Integranden gesucht und diese an den Integrationsgrenzen durch Grenzwertbildung aus-
gewertet wird. Dadurch kann Derive auch einige uneigentliche Integrale lösen, die entweder 
unendliche Integrationsgrenzen haben oder bei denen der Integrand an den Grenzen Singulari-
täten aufweist. 
  
- Hängt der Integrand nur von der Integrationsvariablen ab und sind die Grenzen numerische 
Werte, so wendet Derive im Approximate-Rechenmodus die Simpsonsche Regel zur nähe-
rungsweisen Berechnung des bestimmten Integrals an.   
  
 

5.3 Bestimmen von Grenzwerten 
  
Zum Bestimmen von Grenzwerten gibt es 
 

- den Menübefehl Calculus>Limit, 
- das Grenzwert-Symbol in der Befehlsymbolleiste   
- und die vordefinierte LIM -Funktion 

 
  
Beispiel: 

- Um den Grenzwert der Folge  <
12
13

−
+

n
n > für n → ∞ zu bestimmen, markiert man den Aus-

druck 
12
13

−
+

n
n  im Algebrafenster und wendet den Menübefehl Calculus>Limit  an (oder 

klickt das Grenzwert-Symbol in der Befehlsymbolleiste an).  

- Im daraufhin erscheinenden Dialogfeld ist bei Variable n und bei Limit point inf (für Un-
endlich) einzutippen.  

- Verlässt man das Dialogfeld durch Anklicken von OK , so wird der Grenzwert im Algebra-

fenster in der Form  
12
13lim −

+
∞→ n

n

n

 dargestellt. (Dieser Ausdruck kann mit dem Simplify-

Symbol zu 3/2 vereinfacht werden.) Klickt man im Dialogfeld Simplify  an, so erhält man 
sofort das Ergebnis 3/2. 

 

Man könnte den oben gesuchten Grenzwert auch durch Eingabe des Ausdrucks LIM(
12
13

−
+

n
n , 

n, inf) in der Authorzeile und anschließendes Vereinfachen mit Simplify ermitteln. 
  
Die Syntax der vordefinierten LIM -Funktion lautet: 
 
LIM(f, x, a)  Grenzwert von f(x) für x → a 
LIM(f, x, a, 1)  Rechtsseitiger Grenzwert von f(x) für x → a+ 
LIM(f, x, a, -1)  Linksseitiger Grenzwert von f(x) für x → a- 



 
 

6. Definieren von Konstanten und Funktionen  
 
  
Oft ist es nützlich, Variablen einen fixen Wert zuzuweisen bzw. Funktionen durch einen defi-
nierenden Term festzulegen. In Derive ist das auf zwei Arten möglich: 
 
- durch Eintippen der Definition in der Authorzeile unter Verwendung des Zuweisungsope-

rators  :=   
- oder mit Hilfe des Menübefehls Declare>VariableValue bzw. Declare> Function Defini-

tion   
  
  

6.1 Definieren von Konstanten 
  
Beispiel: 
Will man der Größe a den fixen Wert 2 zuweisen, so kann man 
- in der Authorzeile die Definition  a:=2  eingeben 
- oder den Menübefehl Declare>VariableValue aufrufen und im zugehörigen Dialogfeld als 

Variablennamen a und als Variablenwert 2 eintippen.  
  
Wird nun ein Ausdruck, in dem a vorkommt, mit Simplify vereinfacht, so wird a stets durch 
den  Wert 2 ersetzt. Löst man, zum Beispiel, die Gleichung  x + 5 = a, so erhält man x = -3. 
  
  
 

6.2 Definieren von Funktionen in einer Variablen  
  
Beispiel: 
Will man die Funktion f durch den Term x²-4 definieren, so kann man 
-  entweder die Definition  f(x) := x^2-4  in der Authorzeile eintippen 
-  oder den Menübefehl Declare>FunctionDefinition  aufrufen und im zugehörigen  Dialog-

feld  als Funktionsname f(x) und als Funktionsdefinition x^2-4 eintippen.  
  
Wird nun, zum Beispiel, der Ausdruck f(3) mit Simplify vereinfacht, so erhält man als Ergebnis 
den Funktionswert 5.  
  
  

6.3 Definieren von Funktionen in mehreren Variablen 
  



Will man eine Funktion mit mehreren Variablen definieren, so gibt man in der Authorzeile den 
Funktionsnamen und eine Liste aller unabhängigen Variablen (durch Beistriche getrennt und in 
runde Klammern eingeschlossen), gefolgt vom Zuweisungszeichen  :=  und dem Funktionsterm 
ein.  
Auch mit Hilfe des Menübefehls Declare>Function Definition können solche Funktionen 
definiert werden. 
  
Beispiel: 
- Die Funktion  HYPOTENUSE(a,b)  soll die Länge der Hypotenuse eines rechtwinkeligen 

Dreiecks mit den Kathetenlängen a und b angeben.  

- Durch Eintippen von   HYPOTENUSE(a,b) := SQRT(a^2+b^2) in der Authorzeile wird 
die Funktion definiert.   

- Vereinfacht man nun  HYPOTENUSE(3,4), so erhält man den Wert 5. 

- Vereinfacht man  HYPOTENUSE(3,2x), so erhält man √√√√(9+4x²). 

- Vereinfacht man  HYPOTENUSE(3), so erhält man  √√√√(9+b²). 

- Das letzte Beispiel zeigt, dass der Funktionsaufruf auch weniger Argumente als die Funkti-
onsdefinition enthalten darf. In diesem Fall werden die verbleibenden Variablen nicht er-
setzt.  

  
     

6.4 Hinweise zum Definieren  
 
- Namen von deklarierten Konstanten dürfen auch im Character-Modus aus mehr als einem 
Buchstaben bestehen.  
 
- Ist der Insensitive-Modus voreingestellt, so braucht man bei der Eingabe zwischen Groß- 
und Kleinschreibung nicht zu unterscheiden. Im Algebrafenster  werden Variablenbezeichnun-
gen automatisch immer in Kleinbuchstaben und Namen vordefinierter Derive - Standardfunkti-
onen immer in Großbuchstaben ausgegeben. Namen von userdefinierten Funktionen werden im 
Algebrafenster in jener Schreibweise dargestellt, in der sie erstmalig definiert worden sind.     
  
- Jede Definition hebt gleichzeitig eine frühere Definition unter demselben Namen automatisch 
auf (und zwar ohne Sicherheitsabfrage!).  
  
- Die Entf-Taste löscht nur die Bildschirmzeilen. Variablenbelegungen und Funktionsdefinitio-
nen bleiben weiterhin gültig, auch wenn sie nicht mehr am Bildschirm angezeigt werden. Ver-
gisst man, dass man bestimmten Variablen bereits einen Wert zugewiesen hat, so kann das zu 
überraschenden, falschen Ergebnissen führen.   
  
- Definitionen von Konstanten und Funktionen bleiben so lange aufrecht, bis man 

- das Programm beendet 
- oder  mit File>New ein neues Algebrafenster eröffnet 
- oder unter demselben Namen eine neue Definition eingibt 



- oder unter demselben Namen eine "leere"  Definition eingibt (so hebt, zum Beispiel, die 
Eingabe von   a:=   die früher gemachte Zuweisung a:=2 auf).   

  
 

7.  Vektoren und Matrizen - Listen und Tabellen 
  

7.1  Vektoren  
 
 In Derive ist ein Vektor eine geordnete Liste von Elementen, wobei 
-  die einzelnen Elemente durch Beistriche voneinander getrennt sind  
-  und die Liste durch eckige Klammern begrenzt wird. 
 
Man kann Vektoren  
-  direkt in der Authorzeile eintippen (Beispiel: Eintippen von [5,-2,4] )   
-  oder mit Hilfe des Menübefehls Author>V ector festlegen: Nach dem Aufruf von 

Author>V ector erscheint ein Dialogfeld, in dem zunächst die Dimension des Vektors und 
dann die Werte der einzelnen Elemente einzutippen sind.  

 
Mit Vektoren kann man die üblichen Rechenoperationen ausführen, zum Beispiel: 
 
[3,2,4] + [1,2,3]  ergibt  [4,4,7]    Vektoraddition 
4[3,2,4] bzw. 4*[3,2,4]  ergibt  [12,8,16]   Multiplikation eines Vektors mit einer Zahl 
[3,2,4].[1,2,3]  ergibt  19    Skalares Produkt von Vektoren 
CROSS([3,2,4],[1,2,3])  ergibt  [-2,-5,4]   Vektorielles Produkt von Vektoren 
 
 

7.2  Matrizen 
 
Eine Matrix ist in Derive ein Vektor von Vektoren der gleichen Dimension. Jeder innere Vek-
tor der Liste stellt eine Zeile der Matrix dar.   
 
Man kann eine Matrix  
-  als einen Vektor von Vektoren in der Authorzeile eintippen  
-  oder mit Hilfe des Menübefehl Author>M atrix  festlegen: Nach dem Aufruf von 

Author>M atrix  erscheint ein Dialogfeld, in dem zunächst die Dimension der Matrix und 
dann die Werte der einzelnen Matrixelemente abgefragt werden.   

 
Beispiel:   
- Eintippen des Ausdrucks [[5, -2, 4], [2, 3, 1]]  ergibt eine 2*3-Matrix,  
- dieselbe Matrix kann in Kurzschreibweise auch in der Form  [5, -2, 4; 2, 3, 1]  eingegeben 

werden   
 
Auch die üblichen Matrizenoperationen stehen zur Verfügung, zum Beispiel:   



 
+  - Matrizenaddition, Matrizensubtraktion 
*        Multiplikation einer Matrix mit einer reellen Zahl 
A.B     Produktmatrix von A und B 
v.A     Produkt des Vektors v mit der Matrix A 
A.v     Produkt der Matrix A mit dem Vektor v 
A^n     Produkt A.A.A...A (n-mal) einer quadr. Matrix 
A^-1     Inverse Matrix von A 
DET(A)   Determinante der Matrix A 
A`      Transponierte Matrix von A 
 
 

7.3  Der VECTOR-Befehl 
 
Viele Listen und Tabellen kann man bequem mit Hilfe der vordefinierten VECTOR -Funktion 
erzeugen. Die Syntax dieses Befehls lautet: 
  
VECTOR(u,i,n)  
liefert für n≥1 den Vektor [u(1), u(2),....u([n])]. Im Term u(i) werden für die Variable i der 
Reihe nach die Werte 1,2,...[n] eingesetzt, wobei [n] die größte ganze Zahl ≤ n bezeichnet.  
 
VECTOR(u,i,m,n)  
liefert für m≤n den Vektor [u(m), u(m+1),....,u(m+[n-m])]. Hier werden für die Variable i die 
Werte m,m+1,m+2,... eingesetzt, solange i ≤n ist.  
 
VECTOR(u,i,m,n,s) 
liefert für m≤n und s>0 (bzw. für m≥n und s<0) den Vektor 
[u(m),u(m+s),u(m+2s),...,u(m+s[(n-m)/s])]. Hier werden für i die Werte von m bis n mit 
Schrittweite s eingesetzt.  
 
Wertetabellen von Funktionen kann man bequem mit Hilfe der vordefinierten TABLE -
Funktion erzeugen. TABLE(u,i,n)  hat dieselbe Wirkung wie VECTOR([i,u(i)],i,n) . 
 
Viele Tabellen kann man mit Hilfe zweier ineinander geschachtelter VECTOR -Befehle be-
schreiben.  
  
Beispiele: 
  
*)   Berechnen der ersten 20 Elemente der Zahlenfolge <an > mit  
 an=(2n+1)/(3n-1):   
   VECTOR((2n+1)/(3n-1), n, 20) 
  
*)   Will man die Folge <an> auch graphisch darstellen, so sollte man mit Hilfe eines  VEC-

TOR-Befehls oder TABLE -Befehls eine Liste aus Punkten [n,an] erzeugen:     
  VECTOR([n,(2n+1)/(3n-1)], n, 20)  oder   
  TABLE((2n+1)/(3n-1), n, 20) 



 Die so definierte Punktliste kann durch Anklicken des Plot-Symbols in einem 
2DGraphikfenster gezeichnet werden (siehe Abschnitt 8). 

  
*)   Wertetabelle der Funktion x → x²-1 im Intervall [-2,2] mit Schrittweite 0.5: 
  VECTOR([x,x^2-1], x, -2, 2, 0.5) oder 
  TABLE(x^2-1, x, -2, 2, 0.5) 
 
 Dieser Befehl erzeugt eine Tabelle mit 9 Zeilen und 2 Spalten. Die erste Spalte enthält die 

neun x-Werte -2, -1.5, -1,...,2, die zweite Spalte die zugehörigen Funktionswerte.  
 Durch Transponieren dieser Matrix mit dem ` Operator (Eingeben mit  
 Strg +t)erhält man eine Tabelle, in der die x-Werte die erste Zeile bilden und die zugehö-

rigen Funktionswerte jeweils darunter stehen: 
  VECTOR([x,x^2-1],x,-2,2,0.5)  ̀
  
*)   Eckpunktskoordinaten eines regelmäßigen n-Ecks mit Umkreisradius r (Für n und r  sind 

konkrete Werte zu wählen): 
  VECTOR([r cos(t),r sin(t)], t, 0, 2ππππ, 2ππππ/n)  
  
*)   Tabelle mit den Quadrat-und Kubikzahlen der natürlichen Zahlen von 10 bis 20: 
  VECTOR([x,x^2,x^3], x, 10, 20)  oder  
  VECTOR(VECTOR(x^i, i, 3), x, 10, 20)   
  
*)   Tabelle mit dem kleinen Einmaleins:  
  VECTOR(VECTOR(i.j, j, 10), i, 10) 
  
*)   Tabelle mit dem großen Einmaleins:  
  VECTOR(VECTOR(i.j, j, 10), i, 11, 20)  
  
*)  pascalsches Dreieck:   
  VECTOR([n, VECTOR(COMB(n, k), k, 0, n)], n, 0, 10) 
 
  

8. Weitere 2D-Graphikmöglichkeiten 
  
 

8.1 Zeichnen von Punktlisten und Streckenzügen 
  
Mit Derive ist es auch möglich, durch Koordinaten gegebene Punkte graphisch darzustellen 
bzw. die Punkte einer Liste fortlaufend durch einen Streckenzug  zu verbinden. Markiert man, 
zum Beispiel, im Algebrafenster die Punktliste   

 
 [[1, 1], [3, 1], [3, 2], [1, 2], [1, 1]]  

 
und aktiviert dann ein 2D-Graphikfenster, so werden nach Drücken der Funktionstaste F4 die 
Punkte der Liste im Koordinatensystem dargestellt.. 



  
Nach Anwählen des Graphikmenübefehls Options>Display>Set Points erscheint ein Dialog-
feld mit den Auswahlmöglichkeiten Connect: Yes / No und Size: Small / Medium / Large. 
 
Beim Menüpunkt Connect:Yes/ No  kann man wählen, ob die Punkte der Liste als einzelne 
Punkte oder fortlaufend durch Strecken verbunden gezeichnet werden sollen. Der Menüpunkt 
Size ermöglicht es, die Größe der dargestellten Punkte festzulegen. 
 
   

8.2 Zeichnen von Funktionenscharen 
  
Wird im Algebrafenster ein Vektor aus drei oder mehr Funktionstermen in einer Variablen 
markiert, zum Beispiel [0.5x, 0.5x+1, 0.5x+2, 0.5x+3], und in einem zugehörigen 2D-
Graphikfenster der Plot-Befehl F4 eingegeben, so wird die Schar der entsprechenden Funkti-
onsgraphen gezeichnet. Alle Graphen werden im selben Maßstab und mit gleicher Lage des 
Koordinatenursprungs dargestellt. 
 
 

8.3 Parameterdarstellung ebener Kurven 
  
Eine Graphik in Parameterdarstellung erhält man, wenn man einen Vektor der Form [f(t), 
g(t)], der aus zwei Funktionstermen in ein und derselben Variablen besteht, zum Zeichnen 
markiert. Bei einer Darstellung in kartesischen Koordinaten stellt der Wert der ersten Funktion 
die x-Koordinate und der Wert der zweiten Funktion die y-Koordinate dar.  
   
Beispiel1: 
- Um die in Parameterdarstellung  x(t) = t - sin(t), y(t) = 1 - cos(t)  gegebene Zykloide gra-

phisch darzustellen, gibt man die Funktionsgleichung in der Schreibweise  [t - SIN(t), 1 - 
COS(t)]  im Algebrafenster ein und aktiviert ein 2D-Graphikfenster .  

 
- Nach Aufrufen des Plot-Befehls wird man nun aufgefordert, die Intervallgrenzen für den 

Parameter t einzugeben. (Mit der Tab -Taste kann man von Feld zu Feld springen).    
 
- Daneben kann man wählen, ob eine durchgehende Kurve oder nur einzelne Punkte ge-

zeichnet werden soll. Will man nur einzelne Punkte zeichnen lassen, so muss man auch die 
Anzahl der verschiedenen Werte eingeben, die der Parameter (mit jeweils gleichen Diffe-
renzen) annehmen soll.  

  
Beispiel2: 
Markiert man im Algebrafenster einen Ausdruck, der nur eine Variable enthält, zum Beispiel 
x²-1, so hat man keinen Einfluss auf den Definitionsbereich der Graphik. Will man die Funktion 
y = x²-1 nur im Definitionsbereich [0; 3] graphisch darstellen, so sollte man im Algebrafenster 
nicht x²-1, sondern den Ausdruck [x, x²-1] markieren. In diesem Fall wird man nach dem Auf-
rufen des Plotbefehls aufgefordert, die Grenzen für den x-Wert einzugeben. Daneben kann man 



entscheiden, ob eine durchgehende Kurve oder nur einzelne Punkte des Graphen in diesem 
Intervall gezeichnet werden sollen.  
  
Beispiel3: 
- Will man eine Schar von Kurven zeichnen, die in Parameterdarstellung gegeben sind, so mar-
kiert man zunächst einen entsprechenden Vektor von Ausdruckspaaren, zum Beispiel:   

[[COS(t),SIN(2t)], [2.COS(t),2.SIN(2t)], [3.COS(t),3.SIN(2t)]]  
 
- Schaltet man auf ein 2D-Graphikfenster um und ruft dort den Plotbefehl auf, so wird man 
aufgefordert, die Intervallgrenzen für den Parameter t einzugeben. Anklicken der Option 
"Appply parameters to rest of plotlist"  bewirkt, dass die eingegebenen Grenzen für alle 
Kurven der Schar gelten. (Andernfalls werden die Intervallgrenzen für jede der drei Kurven 
einzeln abgefragt.)  
 
  

9. Kennenlernen der 3D-Graphik von Derive  
 
 

9.1 Graphen von Funktionen von R² nach R 
  
Den Graph einer Funktion f: R² → R kann man sich als Fläche im R3 vorstellen. Jedem Punkt 
(x/y) aus R² wird der Funktionswert z = f((x/y)) als "Höhe" über dem Punkt (x/y) zugeordnet. 
Derive kann solche Funktionsgraphen in 3DGraphikfenstern darstellen. 
  
Markiert man im Algebrafenster  
- einen Ausdruck u(x, y), der zwei Variablen enthält (zum Beispiel x²+y²),  
- oder eine Gleichung der Form z = u(x, y), wobei z eine Variable und u(x, y) ein Ausdruck 

in genau zwei anderen Variablen ist (zum Beispiel z = x²+y²), 
- oder eine Gleichung der Form u(x, y, z) = c, wobei c eine reelle Konstante und u(x, y, z) 

ein Ausdruck in drei Variablen x, y, z ist, der in z linear ist (zum Beispiel x²+y²-z = 3, in 
diesem Fall kann das Programm z explizit ausdrücken)  

 
und aktiviert dann ein 3D-Graphikfenster, so wird nach Aufruf des Plotbefehls (dh. Anklicken 
des Plot-Symbols oder Drücken der Funktionstaste F4 oder Anwählen des Menüpunkts Insert 
> Plot) der entsprechende Funktionsgraph als Fläche im Raum dargestellt. 
  
Markiert man eine Liste von Ausdrücken der obigen Form, so wird die Schar der entsprechen-
den Funktionsgraphen gezeichnet. (Dabei ist allerdings zu beachten, dass eine dreielementige 
Liste der Form [u1(x,y), u2(x,y), u3(x,y)] als Parameterdarstellung einer Fläche im R³ und nicht 
als Funktionenschar aufgefasst wird (siehe Abschnitt 9.3 Parameterdarstellungen im R³)). 
 
Grundsätzlich zu beachten ist, dass die in den Funktionstermen verwendeten Variablenbezeich-
nungen den kartesischen Koordinaten x, y, z in alphabetischer Reihenfolge zugeordnet werden. 
So wird, zum Beispiel, dem Funktionsterm r²πh der Graph der Funktion (x, y) → y²πx zuge-
ordnet (h → x und r → y).  



 
Beispiele: 
- Markiert man  x+2y+3z = 6 , so wird die zugehörige Ebene gezeichnet. Markiert man die 

Liste [x + y + z = 0, x + y – z = 0, x + y + 2z = 0], so werden die drei beschriebenen Ebe-
nen im selben Koordinatensystem gezeichnet.    

- Interessante Beispiele für Funktionen f:R² → R findet man im File PLOT3D.MTH, das 
mit Hilfe von File > Load Math File geladen werden kann (siehe dazu Abschnitt 11.1 
Speichern und Laden von Inhalten des Algebrafensters). 

  
 

9.2  Die 3D-Graphik-Menübefehle 
 
Analog zur 2D-Graphik gibt es auch hier vielfältige Möglichkeiten, die graphische Darstellung 
zu verändern. 
 

9.2.1  Stauchen und Strecken der Graphik 
 
Wie bei der 2D-Graphik kann man auch hier mit Hilfe der Funktionstasten F9 und F10 bzw. 
mit Hilfe der Menübefehle Set > Plot Region und Set > Plot Range den dargestellten Bereich 
der Koordinateachsen und mit Set > Aspect Ratio das Verhältnis der Achsenmaßstäbe verän-
dern. (siehe 2.2.1 Stauchen und Strecken des Bildschirmausschnitts:, 2.2.5 Direkte Eingabe der 
Bildschirmränder)  
 
Außerdem kann die dargestellte Graphik mit Hilfe der Bild ↑↑↑↑- und der Bild ↓↓↓↓-Taste (oder durch 
Anklicken des Magnify Plots-Symbols und des Shrink Plots-Symbols) vergrößert und ver-
kleinert werden: Der dargestellte Ausschnitt des Koordinatensystems bleibt in diesem Fall un-
verändert, aber der Augpunkt wird näher zum Koordinatenursprung hin bzw. weiter davon 
weg bewegt.  
 
  

9.2.2 Änderung der Zahl der Gitterlinien und der Zeichenfarbe 
 
Nach Anwählen des Menüpunktes Edit > Plot oder Insert > Plot (bzw. Funktionstaste F4) 
erscheint das Dialogfeld Plot Parameters, in dem unter Number of Panels die Zahl der 
Gitterlinien in x-Richtung bzw. in y-Richtung festgelegt werden kann.  
 
Anklicken des Weiter-Feldes öffnet das Dialogfeld Plot Colors, in dem die Zeichenfarbe ge-
wählt werden kann. Zur Auswahl stehen die Farbschemen Rainbow, Wire  Grid , Gray Scale, 
Red&Blue Checker, Heat Wave, Auto Plot Color und Custom. Durch Anklicken des Fer-
tig Stellen - Feldes wird die Eingabe bestätigt. 
 
Ist der Menübefehl Options > Change Plot Colors aktiviert, so ändert Derive beim Zeichnen 
mehrerer Graphen automatisch die Zeichenfarbe.  
 



 

9.2.3 Löschen von Graphiken 
 
Durch Drücken der Entf-Taste (oder Anklicken des Delete-Symbols in der Symbolleiste oder 
Anwählen des Menübefehls Edit > Delete Plot) kann man eine  zuvor durch Anklicken mit der 
Maus markierte Graphik löschen. 
 
Edit > Delete all Plots (oder Strg + d) löscht alle im aktuellen Fenster vorhandenen Graphi-
ken.   
 
 

9.2.4 Untersuchen von Graphen mit dem Spurmodus 
 
Mit Hilfe der Funktionstaste F3  (oder des Menübefehls Options > Trace Plots) kann auch bei 
der 3D-Graphik der Spurmodus ein- und ausgeschaltet werden. In diesem Modus ist jeweils 
eine Gitterlinie in x-Richtung und eine Gitterlinie in y-Richtung farblich gekennzeichnet. Die 
Koordinaten des Schnittpunktes dieser Gitterlinien können in der Statuszeile abgelesen werden.  
  
Durch Drücken der Tastenkombination Shift + ←←←←  bzw. Shift + →→→→ wird die nächste Gitterlinie 
in x-Richtung markiert, durch Shift + ↑↑↑↑ bzw. Shift + ↓↓↓↓ die nächste Gitterlinie in y-Richtung. 
Auch durch Anklicken einer Gitterlinie mit der linken Maustaste kann man diese markieren. 
 
 

9.2.5 Rotieren von Graphiken 
 
Drücken der Cursortasten ↑, ↓, ←, →  (bzw. Anklicken der entsprechenden Symbole in der 
Symbolleiste) bewirkt, dass die Graphik um 5° nach oben, unten, links bzw. rechts gedreht 
wird. (Im Dialogfeld Rotation des Menüpunktes Options > Display kann man die Größe die-
ses Rotationsschrittes verändern) 
  
Außerdem kann man durch Anwählen des Menübefehls Options > Rotate Plots (oder Ankli-
cken des Rotate Plots-Symbols oder Drücken der Tastenkombination Strg + t)  die Graphik in 
Rotation um die z-Achse versetzen. Drücken der Cusortasten ← bzw. → während der Rotati-
on ändert den Drehsinn. Drücken der Esc-Taste (oder ein Klick mit der linken Maustaste) be-
endet die Rotation. 
    
 

9.2.6 Automatische Skalierung der z-Achse  
 
Hilfreich beim Zeichnen von Graphen ist die Möglichkeit, durch Anklicken des Menüpunkts  
Options > Autoscale New Plots die automatische Skalierung der z-Achse einzuschalten.  
 



9.2.7 Darstellung der Koordinatenachsen, der Box etc. 
 
Mit dem Menübefehl Options > Display (auch mit der Funktionstaste F11 oder durch Dop-
pelklick mit der linken Maustaste anwählbar) kann die Darstellung der Koordinatenachsen (A-
xes), der Box (Box) und  der Legende ((Legend),das ist das kleine Koordinatendreibein in der 
linken oberen Bildschirmecke) verändert werden: Man kann jeweils die Zeichenfarbe und die 
Beschriftung festlegen, und außerdem entscheiden, ob die Achsen, die Box bzw. die Legende 
gezeichnet werden oder nicht.   
 
Im Untermenüpunkt Options > Display > Background kann die Hintergrundfarbe gewählt 
werden; der Punkt Options > Display > Rotation ermöglicht es, die Rotationsgeschwindig-
keit zu verändern. 
 
 

9.2.8 Beschriften von Graphiken 
 
Anwählen des Menübefehls Insert > Annotation bzw. Drücken der Funktionstaste F12 er-
möglicht es, ein Textfeld einzufügen. Im Dialogfeld ist der gewünschte Text einzutippen; au-
ßerdem können Schriftart, Schriftgröße und Farbe gewählt werden. Durch Anklicken des ein-
gefügten Textfeldes mit der linken Maustaste und Ziehen der Maus mit gedrückter linker 
Maustaste kann die Position des Textfeldes verändert werden.  
 
Um den Inhalt oder das Layout eines eingefügten Textfeldes zu verändern, klickt man dieses 
mit der Maus an und wählt den Menüpunkt Edit > Annotation.  
 
Mit Edit > Delete Annotation kann man ein einzelnes zuvor mit der Maus markiertes Text-
feld, mit Edit > Delete All Annotations alle vorhandenen Textfelder löschen.  
 
   

9.2.9 Einbetten von Graphiken ins Algebrafenster 
 
Der Menübefehl File > Embed bettet ein Bild des Graphikfensters im zugehörigen Algebra-
fenster ein. 
 
Durch Anklicken und Ziehen des Randes mit der Maus kann man die Größe dieses eingebette-
ten Bildes verändern.  
 
Ein Doppelklick auf das eingebettete Bild aktiviert das zugehörige Graphikfenster und ermög-
licht es, dort Änderungen vorzunehmen (zum Beispiel das Achsenverhältnis mit Set > Aspect 
Ratio zu korrigieren). Anschließend können die Änderungen mit dem Graphikmenübefehl File 
> Update ins eingebettete Bild übernommen werden. 
 
 



9.3 Parameterdarstellungen im R³ 
 
Neben Graphen von Funktionen f:R² → R kann man auch Kurven und Flächen im R³, die in 
Parameterdarstellung gegeben sind, graphisch darstellen. 
 
Eine Liste der Form  [u1(s,t), u2(s,t), u3(s,t)], die aus drei Funktionstermen in denselben zwei 
Variablen s und t besteht, beschreibt eine Fläche im dreidimensionalen Raum, eine Liste der 
Form [u1(t), u2(t), u3(t)]  eine Raumkurve. 
 
In diesem Fall kann man nach Aufruf von Edit>Plot  bzw. Insert>Plot bzw F4 nicht nur die 
Zahl der Gitterlinien wählen, sondern auch Schranken für die beiden Parameter s und t ange-
ben.  
 
  

9.3.1 Geraden und Ebenen in Parameterdarstellung 
 
Im Mathematikunterricht der Sekundarstufe II werden Parameterdarstellungen von Geraden 
und Ebenen im R³ behandelt. Nun ist es möglich, durch Parametergleichungen festgelegten 
Geraden oder Ebenen mit Hilfe von Derive zu visualisieren.  
 
 

9.3.2 Einbetten ebener Kurven in ein dreidimensionales Koordinatensystem 
 
Der Parameterausdruck [r cos(t), r sin(t)] mit 0 ≤ t≤ 2π beschreibt einen Kreis mit Mittelpunkt 
(0/0) und Radius r in der zweidimensionalen x-y-Ebene. Ergänzt man als dritte Koordinate 
einen konstanten Wert, so wird der Kreis parallel zu einer Koordinatenebene in den R³ einge-
bettet: 
 
[r cos(t),  r sin(t), 0], wobei 0≤ t ≤ 2π     Kreis  in der x-y-Ebene im R³ 
[r cos(t), 0, r sin(t)], wobei 0≤ t ≤ 2π      Kreis in der x-z-Ebene im R³ 
[0, r cos(t), r sin(t)], wobei 0≤ t ≤ 2π Kreis in der y-z-Ebene im R³ 
[r cos(t), r sin(t), 3], wobei 0≤ t ≤ 2π Kreis parallel zur x-y-Ebene im R³ im Ab-

stand 3. 
 
Setzt man für r einen konkreten Zahlenwert ein, so wird die entsprechende Kreislinie gezeich-
net. Belässt man die Variable r als zweiten Parameter, so wird eine gefärbte Kreisfläche, Kreis-
sektorfläche bzw. Kreisringfläche dargestellt.  
  
Beispiel: 

   [2 cos(t),  2 sin(t), 0],  wobei 0≤ t ≤ 2π      Kreislinie  in der x-y-Ebene  
   [r cos(t),  r sin(t), 0],  wobei 0≤ t ≤ 2π, 0 ≤ r ≤ 2    Kreisfläche  in der x-y-Ebene  
   [r cos(t),  r sin(t), 0],  wobei 0≤ t ≤ π/2, 0 ≤ r ≤ 2    Viertelkreisfläche in der x-y-Ebene  
   [r cos(t),  r sin(t), 0],  wobei 0≤ t ≤ 2π, 1 ≤ r ≤ 2    Kreisringfläche  in der x-y-Ebene  

 



Durch Variieren der Belegung der z-Koordinate kann man weitere interessante Gebilde be-
schreiben: 
 
Beispiel: 
[2 cos(t),  2 sin(t), t],  wobei 0≤ t ≤ 2π      Spiralförmige Kurve im R³ 
[r cos(t),  r sin(t), t],  wobei 0≤ t ≤ 2π, 0 ≤ r ≤ 2   Fläche im R³ 
[2 cos(t),  2 sin(t), s],  wobei 0≤ t ≤ 2π, 0 ≤ s ≤ 4   Drehzylinder mit Radius 2 und Hö-

he 4 
 
Genauso kann man jede andere durch Parameterdarstellung gegebene ebene Kurve in den R³ 
einbetten. 
 

9.3.3 Rotation des Graphen einer Funktion f: R →→→→ R um die x- bzw. um die 
y-Achse 
 
Der Parameterausdruck [x, f(x), 0] bettet den Graphen der Funktion f in die x-y-Ebene des R³ 
ein. Bei der Rotation um die x-Achse beschreibt jeder Punkt [x0, f(x0), 0] des Graphen einen 
Kreis mit Mittelpunkt [x0, 0, 0] und Radius f(x0), der parallel zur y-z-Ebene liegt. Der Rotati-
onskörper im Bereich a ≤ x ≤ b kann daher parametrisch beschrieben werden als 
 
 [x, f(x) cos(t), f(x) sin(t)],  wobei 0 ≤ t≤ 2π und  a ≤ x ≤ b. 
 
Analog dazu beschreibt die Liste 
 
 [x cos(t), f(x), x sin(t)], wobei 0 ≤ t≤ 2π und  a ≤ x ≤ b 
 
den Drehkörper, der bei Rotation des Graphen von f im Intervall a ≤ x ≤ b um die y-Achse 
entsteht. 
 
 

9.3.4 Rotation einer ebenen Kurve um eine Koordinatenachse 
 
Analog zu 9.3.3 kann jede in Parameterdarstellung [x(t), y(t)]  gegebene ebene Kurve parallel 
zu einer Koordinatenebene in den R³ eingebettet und um eine Koordinatenachse gedreht wer-
den. 
 
[x(t), y(t) cos (s), y(t) sin(s)]     Drehkörper, der durch Rotation der in der x-y-Ebene 

eingebetteten Kurve um die x-Achse entsteht 
[x(t) cos(s), y(t) , x(t) sin(s)]     Drehkörper, der durch Rotation der in der x-y-Ebene 

eingebetteten Kurve um die y-Achse entsteht 
   
Beispiele: 
- Durch Einbettung der Ellipse [a cos(t), b sin(t)] in die x-y-Ebene des R³ und Rotation um 

die x- bzw. um die y-Achse erhält man die beiden Rotationsellipsoide: 
  [a cos(t), b sin(t) cos(s), b sin(t) sin(s)]  und  



  [a cos(t) cos(s), b sin(t), a cos(t) sin(s)] ,wobei 0≤ t ≤ 2π, 0 ≤ s ≤ 2π. 
 (Für a und b sind jeweils konkrete Zahlen zu wählen) 
 
- Versuchen Sie, die obige Ellipse in die x-z-Ebene einzubetten und um die x- bzw. um die z-

Achse zu drehen. 
 
- Durch [3 + cos(t), sin(t)] wird ein Kreis im R² mit Mittelpunkt (3/0) und Radius 1 be-

schrieben. Einbetten dieses Kreises in die x-y-Ebene und Rotation um die y-Achse erzeugt 
einen Torus: 
  [(3 + cos(t))cos(s), sin(t), (3 + cos(t))sin(s)], wobei 0≤ t ≤ 2π, 0 ≤ s ≤ 2π 
 Durch Erhöhen der Zahl der Gitterlinien kann man die Qualität der Darstellung verbessern. 
Durch Variieren der Parameterbelegungen, zum Beispiel 0≤ t ≤ 2π ∧ 0 ≤ s ≤ π  bzw. 0≤ t ≤ 
π ∧ 0 ≤ s ≤ 2π, kann man verschiedene Teile des Torus darstellen. 

   
 

9.4 Darstellung von Punktlisten im 3D-Graphikfenster 
 
Auch einzelne Punkte und Streckenzüge können im dreidimensionalen Koordinatensystem dar-
gestellt werden: 
 
[x0, y0, z0] Zeichnet den Punkt [x0, y0, z0] 
 
[[x0, y0, z0], [x1, y1, z1], …, [xn, yn, zn]] Zeichnet den Streckenzug, der die Punk-

te fortlaufend verbindet 
 
[[x0, y0, z0]], [[x 1, y1, z1]], …, [[xn, yn, zn]]] Zeichnet die einzelnen Punkte 
 
[[[x 11, y11, z11], [x12, y12, z12], …, [x1n, y1n, z1n]], [[x 21, y21, z21], [x22, y22, z22], …, [x2n, y2n, z2n]], 
…….., [[xm1, ym1, zm1], [xm2, ym2, zm2], …, [xmn, ymn, zmn]]]   
Eine Liste aus m gleich langen Punktlisten erzeugt die Fläche, die von diesen m Streckenzügen 
aufgespannt wird. 
 
Beispiele: 
Definieren Sie, zum Beispiel, a:= [0, 0, 0], b:= [4, 0, 0], c:= [4, 3, 0], d:= [0, 3, 0], e:= [0, 0, 
5], f:= [4, 0, 5], g:= [4, 3, 5], h:= [0, 3, 5] als Eckpunkte eines Quaders, sowie s:= [2, 1.5, 5] 
und t:= [2, 1.5, -5] . 
 
Dann beschreibt: 
 
[a, b, c, d, a]   die Umfangslinie des Rechtecks ABCD 
  
[[a], [b], [c], [d], [a]]   
bzw. [a; b; c; d; a]   

die einzelnen Punkte A, B, C, D 

  
[[a, b], [d, c]]  
bzw. [a, b; d, c]   

die Fläche des Rechtecks ABCD  
(Auf die Reihenfolge der Punkte achten! Versu-



chen Sie vergleichsweise auch [a, b; c, d]) 
  
[[a, b], [a, c]] bzw. [a, b; a, c]   die Fläche des Dreiecks ABC 
  
[[a, b, c, d, a], [e, f, g, h, e]]  
bzw. [a, b, c, d, a; e, f, g, h, e]   

die Mantelfläche des Quaders ABCDEFGH 

  
[[a, b, c, d, a], [s, s, s, s, s]]  
bzw. [a, b, c, d, a; s, s, s, s, s]   

die Mantelfläche der Pyramide mit Basis ABCD 
und Spitze S. 

  
[[s, s, s, s, s], [a, b, c, d, a], [t, t, t, t, t]] 
bzw [s, s, s, s, s; a, b, c, d, a; t, t, t, t, t] 

die Oberfläche der Doppelpyramide mit den Eck-
punkten A, B, C, D, S, T 

      
 
 

10. Übersicht über die Programmierbefehle von Derive 
  
 
Derive hat nicht nur hervorragende numerische, algebraische und graphische Fähigkeiten, son-
dern stellt darüber hinaus auch gute Programmiermöglichkeiten zur Verfügung. Einige wenige 
rasch erlernbare Begriffe reichen aus, um die im Rahmen des Mathematikunterrichts benötigten 
Algorithmen beschreiben zu können. 
  
In diesem Abschnitt werden die in Derive vordefinierten Programmierbefehle vorgestellt. Diese 
Übersicht soll es ermöglichen, die genaue Syntax der einzelnen Begriffe bei Bedarf rasch nach-
zuschlagen. 
  

10.1 Wertzuweisung mit :=  
  
In jeder Programmiersprache gibt es die Möglichkeit, Variablen einen Wert zuzuweisen bzw. 
Funktionen durch einen definierenden Term festzulegen. Das entsprechende Symbol in Derive 
ist  :=, dessen Einsatzmöglichkeiten bereits in Abschnitt 6. Definieren von Konstanten und 
Funktionen vorgestellt worden sind. 
  
  

10.2 Zusammenfassen von Aktionen durch Listenklammern  
  
Derive akzeptiert als Eingabe in der Authorzeile nur entweder einen mathematischen Ausdruck 
oder einen in Anführungszeichen geschriebenen Text. Will man mehrere Ausdrücke in einer 
einzigen Zeile eingeben, so muss man diese Ausdrücke zu einer Liste zusammenfassen: Die 
Liste ist durch zwei eckige Klammern zu begrenzen, die einzelnen Ausdrücke sind durch Bei-
striche zu trennen. 
 
  



10.3 Auswahl von Aktionen mit dem IF-Befehl  
  
Ein wesentliches Element jeder Programmiersprache ist die Möglichkeit, Entscheidungen zwi-
schen zwei verschiedenen Aktionen zu treffen. In Derive gibt es dazu den IF-Befehl, der in 
allgemeinster Form folgendermaßen definiert ist: 
  
IF(Bedingung, dann, sonst, sonstig) 
  
"Bedingung" ist dabei eine Relation (oder wird andernfalls wie die Relation "Bedingung = 0" 
behandelt), "dann", "sonst" und "sonstig" sind Ausdrücke.  
  
Wird der IF-Ausdruck vereinfacht, so versucht Derive festzustellen, ob die Relation "Bedin-
gung" wahr oder falsch ist. Im ersten Fall wird der vereinfachte Wert von "dann" ausgegeben, 
im zweiten Fall der vereinfachet Wert von "sonst". Kann die Gültigkeit von "Bedingung" nicht 
festgestellt werden, so wird der vereinfachte Wert von "sonstig" ausgegeben. 
  
Daneben stehen auch die folgenden Varianten  des IF-Befehls zur Verfügung:  
  
IF(Bedingung, dann, sonst) 
Kann nicht entschieden werden, ob die Relation "Bedingung" wahr oder falsch ist, so wird in 
diesem Fall nochmals der gesamte IF-Ausdruck ausgegeben. 
 
  
IF(Bedingung, dann) 
Ist "Bedingung" wahr, so wird der vereinfachte Wert des Ausdrucks "dann" ausgegeben, an-
dernfalls ein Fragezeichen.  
  
IF(Bedingung) 
Ist "Bedingung" wahr, so wird 1 ausgegeben, andernfalls 0. 
 
  
Beispiele: 
 
*)   FAK(n)  liefert die Zahl n Faktorielle:  FAK(n) := IF(n=0, 1, n.FAK(n-1))  
 
*)  QS(n) liefert die Quersumme der Zahl n:  
 QS(n) := IF(n<10, n, MOD(n,10) + QS(FLOOR(n,10))) 
 
*) BINÄR(n) wandelt eine dekadische natürliche Zahl n in Binärdarstellung um: 
 BINÄR(n) := IF(n=0, 0, MOD(n,2) + 10.BINÄR(FLOOR(n,2)))  
 
*)  GGT(a,b) liefert den größten gemeinsamen Teiler von a und b: 
 GGT(a,b) :=  IF(b=0, a, GGT(b, MOD(a,b)) 
 
*)  UMKEHR(n) kehrt die Ziffernfolge einer natürlichen Zahl n um: 
 UMKEHR(n) :=  
 IF(n<10, n, UMKEHR(FLOOR(n,10)+MOD(n,10).10FLOOR(LOG(n,10))) 



  
 
 

10.4  Listen mit dem VECTOR- bzw. dem SELECT-Befehl  
  
Der bereits in Abschnitt 7.3  Der VECTOR-Befehl vorgestellte VECTOR-Befehl kann in ge-
wissem Sinn mit den FOR-Schleifen der Programmiersprachen BASIC oder PASCAL vergli-
chen werden. Aus Gründen der Vollständigkeit sei die Syntax nochmals angegeben: 
 
  
VECTOR(u,i,n)  
liefert für n≥1 den Vektor [u(1), u(2), ...., u(n)]. Im Term u(i) werden der Reihe nach die Wer-
te 1,2,....n eingesetzt. Ist n nicht ganzzahlig, so wird die größte ganze Zahl kleiner gleich n als 
letztes Argument genommen. Für n<1 wird die leere Liste [] ausgegeben.  
  
VECTOR(u,i,m,n)  
liefert für m≤n den Vektor [u(m), u(m+1),...., u(m+[n-m])], wobei [n-m] die größte ganze Zahl 
≤ n-m bedeutet. Für m>n wird die leere Liste [] erzeugt.  
  
VECTOR(u,i,m,n,s) 
liefert für m≤n und s>0 (bzw. für m≥n und s<0) den Vektor [u(m),u(m+s),u(m+2s),..., 
u(m+s.[(n-m)/s])]. Hier werden für i die Werte von m bis n mit Schrittweite s eingesetzt.  
  
VECTOR(u,i,v)   
Ist das dritte Argument ein Vektor v, so werden für i die einzelnen Elemente von v eingesetzt. 
  
In der Derive-Version 3 ist ein neuer, dem VECTOR -Befehl verwandter Programmierbefehl 
dazugekommen. Dieser  SELECT-Befehl ermöglicht es, Elemente eines Vektors bzw. Ele-
mente einer vorgegebenen Folge zu finden, die ein bestimmtes Auswahlkriterium erfüllen: 
  
SELECT(u,i,m,n) 
liefert einen Vektor jener Elemente i, für die die Relation u(i) wahr ist. Dabei durchläuft i die 
Werte von m bis maximal n mit Schrittweite 1.  
  
SELECT(u,i,m,n,s) 
Wie beim VECTOR-Befehl kann man auch hier als 5.Argument eine Schrittweite s angeben, 
mit der die Werte von m bis n durchlaufen werden. 
  
SELECT(u,i,v) 
liefert einen Vektor jener Elemente i des Vektors v, für die die Relation u(i) wahr ist.   
  
 
Beispiele:  
*) PRIM(n) liefert alle Primzahlen kleiner gleich n: 
 PRIM(n) := SELECT(PRIME(i),i,n) 
 



*) GOLD(n) liefert alle Goldbachdarstellungen der geraden Zahl n (dh. Darstellungen von n 
als Summe von zwei Primzahlen):  
GOLD(n) := VECTOR([x, n-x],x,SELECT(PRIME(x) AND PR IME(n-x),x,3, n/2)) 
 
*) ZWILL(a,b) liefert alle Primzahlzwillinge im Intervall [a; b]: 
 ZWILL(a,b)  := VECTOR([x, x+2], x, SELECT(PRIME(x) AND   
 PRIME(x+2), x, 6.FLOOR(a, 6) + 5, b, 6)) 
 
 

10.5  Iterationen mit dem ITERATE-Befehl  
  
In Derive stehen zwei vordefinierte allgemeine Iterationsbefehle zur Verfügung: 
  
ITERATES(f,x,a,n)  
liefert für die Funktion x → f(x) eine Liste der ersten n+1 Glieder der Iterationsfolge  a, f(a), 
f(f(a)), f(f(f(a))),....  mit dem Startwert a. 
  
ITERATE(f,x,a,n)  
liefert nur das (n+1)-te Glied der obigen Folge.  
  
Hinweise: 
- Bei den Funktionen ITERATES  und ITERATE  darf das zweite Argument x auch ein Vek-
tor von Variablen sein. In diesem Fall ist als drittes Argument ein Vektor von Startwerten für 
diese Variablen einzugeben. 
  
- Lässt man im ITERATES - bzw. ITERATE -Befehl das vierte Argument n weg, so wird die 
Iteration so oft durchgeführt, bis ein Element der Iterationsfolge gleich einem der vorherigen 
ist. 
  
- Ist das vierte Argument n im ITERATES - bzw. ITERATE -Befehl eine negative ganze Zahl, 
so wird die Iteration n-mal auf die inverse Funktion von f angewendet, dh. man erhält die Folge  
a, f*(a), f*(f*(a)),... 
  
  
Beispiele: 
 
*) PRIMERST(n)  liefert die ersten n Primzahlen: 
 PRIMERST(n) := ITERATES(NEXT_PRIME(i), i, 2, n-1) 
 
*)  ARITHS(a0,d,n) liefert die ersten n Glieder der arithmetischen Folge mit Startwert a0 und 
Differenz d:   ARITHS(a0,d,n) :=  ITERATES(i+d, i, a0, n) 
 
*) FAKIT(n) liefert die Zahl n Faktorielle: 
 FAKIT(n) := (ITERATE([i+1, (i+1).j], [i,j], [0,1], n)) 2 

 
 



10.6  Summen und Produkte  
  
Zum Addieren bzw. Multiplizieren einer Folge von Ausdrücken gibt es die vordefinierte SUM-
Funktion und die analoge PRODUCT-Funktion. Diese können folgendermaßen verwendet 
werden: 
  
SUM(u,i,m,n) 
liefert für m≤n die Summe u(m)+u(m+1)+...+u(m+[n-m]), wobei wieder [n-m] die größte gan-
ze Zahl ≤n-m bezeichnet. Analog zum VECTOR-Befehl kann man auch hier als fünftes Argu-
ment eine Schrittweite s angeben, mit der die Werte von m bis n durchlaufen werden.  
  
SUM(u,i,v) 
Ist das dritte Argument ein Vektor v, so durchläuft die Summationsvariable i der Reihe nach 
die Elemente dieses Vektors. 
  
SUM(v) 
liefert die Summe der Elemente des Vektors v. 
 
  

10.7  Befehle zum Operieren mit Listen  
  
Sehr hilfreich beim Formulieren von Algorithmen sind die folgenden vordefinierten Listenope-
rationen: 
  
DIMENSION(v)  
liefert die Anzahl der Elemente des Vektors v. 
  
ELEMENT(v,i) bzw. v SUB i 
liefert das i-te Element des Vektors v. Der Operator SUB kann auch bequem durch Drücken 
der Tastenkombination Strg + b eingegeben werden. 
  
APPEND(v1, v2,...., vn) 
liefert einen Vektor, der der Reihe nach aus den Elementen der Vektoren v1 bis vn besteht. Ist 
v eine Matrix, so liefert APPEND(v) einen Vektor, der aus den einzelnen Matrixelementen von 
v besteht. 
  
DELETE(v,i)  
liefert eine Kopie des Vektors v ohne das i-te Element. 
 
  
INSERT(u,v,i) 
liefert eine Kopie des Vektors v, in der der Ausdruck u vor dem i-ten Element eingefügt wor-
den ist. 
   
REPLACE(u,v,i)  



liefert eine Kopie des Vektors v, in der das i-te Element durch den Ausdruck u ersetzt worden 
ist. 
  
REVERSE(v) 
liefert eine Kopie des Vektors v, bei der die Elemente in umgekehrter Reihenfolge angeordnet 
sind.  
  
  
Derive stellt darüber hinaus noch eine Vielzahl an nützlichen vordefinierten Funktionen zur 
Verfügung. Über den Menüpunkt Help>Contents kann man eine Übersicht aller dieser Funk-
tionen auf dem Bildschirm aufrufen.  
  
  

11. Laden - Speichern - Drucken 
  

11.1 Speichern und Laden von Inhalten des Algebrafensters 
   
Mathematische Ausdrücke, die beim Arbeiten mit Derive entstanden sind, und sogar ganze 
Arbeitsblätter mit eingebetteten Texten und Graphiken, kann man mit Hilfe des Menübefehls  
File>SaveAs  abspeichern und später in Derive öffnen und weiterbearbeiten. 
  
Nach dem Aufruf von File>SaveAs erscheint ein Dialog, der die Auswahl des Ziel-Ordners 
und die Eingabe des Namens der zu speichernden Datei ermöglicht. Außerdem kann man wäh-
len, ob ein Math-File oder ein DfW-File angelegt werden soll. 
 

11.1.1 DfW-Files (*.dfw) 
 
Entscheidet man sich für den Dateityp DfW-File, so wird der gesamte Inhalt des aktiven Ar-
beitsblattes (mit allen Textfeldern, eingebetteten Graphiken und OLE-Objekten) und auch die 
aktuelle Einstellung der einzelnen Statusvariablen gespeichert. Aktuelle vom Benutzer einge-
gebene Konstanten- und Funktionsdefinitionen bleiben beim Speichern ebenfalls erhalten (auch 
dann wenn die zugehörige Definitionszeile im Arbeitsblatt bereits mit Entf gelöscht worden 
ist).   
 
Mit Hilfe des Menübefehls File>Open kann ein abgespeichertes DfW-File in ein Algebrafens-
ter geladen werden.  
 
 

11.1.2 Math-Files (*.mth) 
 
In einem Math-File werden nur mathematische Ausdrücke und/oder Einstellungen der Status-
variablen des aktuellen Arbeitsblattes abgespeichert, Textfelder und Graphiken können nicht 



mitgespeichert werden. Aktuelle vom Benutzer eingegebene Konstanten- und Funktionsdefini-
tionen, deren Definitionszeile bereits gelöscht ist, gehen beim Speichern ebnfalls verloren. 
Klickt man im SaveAs-Dialog den Dateityp Math-File an, so kann man wählen, ob nur die Be-
legung der Statusvariablen, nur die mathematischen Ausdrücke oder beides gespeichert werden 
soll. Außerdem kann man wahlweise alle oder nur die aktuell markierten Bildschirmzeilen spei-
chern.    
 
Zum Laden von Math-Files stehen die Menübefehle File>Open und File>Load zur Verfü-
gung.  In beiden Fällen erscheint nach Anwählen des Menüpunktes ein Dialog, der die Auswahl 
des Ordners und des gewünschten Dateinamens ermöglicht 
 
File>Open öffnet ein neues Algebrafenster und lädt die Dateiinhalte in dieses neue Fenster. 
 
File>Load fügt den Dateiinhalt den Inhalten des aktuellen Algebrafensters hinzu. Dabei stehen 
vier Möglichkeiten zur Auswahl:  
 
File>Load>Math File Die mathematischen Ausdrücke bzw. Statusvariablenbele-

gungen einer mth-Datei werden geladen und im aktuellen 
Algebrafenster als weitere Bilschirmzeilen hinzugefügt.   

File>Load>Data File Ein Datenfile (*.dat) wird ins aktuelle Algebrafenster gela-
den und dort als Matrix dargestellt.    

File>Load>Demo File Ein Demonstrationsfile, das Einsatzmöglichkeiten von Deri-
ve erläutert, wird (durch wiederholtes Drücken der Enter-
Taste) Zeile für Zeile ins aktuelle Algebrafenster geladen. 
Demo-Files haben die Extension .dmo.  

File>Load>Utility File Die mathematischen Ausdrücke bzw. Statusvariablenbele-
gungen einer mth-Datei werden geladen, aber nicht am Bild-
schirm angezeigt (d.h. die in der Datei enthaltenen Definitio-
nen und Belegungen stehen zur Verfügung, obwohl sie nicht 
am Bildschirm aufscheinen). 

 
 

11.2 Arbeiten mit der Windows-Zwischenablage 
 
  
Wie bei jedem anderen Windowsprogramm können auch bei Derive markierte Bilschirmberei-
che in die Zwischenablage übertragen bzw. Inhalte der Zwischenablage in ein aktives Algebra-
fenster eingefügt werden. Dabei stehen folgende Möglichkeiten zur Auswahl: 
 
Im Algebrafenster: 
 
Edit>Cut   Schneidet den markierten Bereich aus und überträgt ihn in die 

Zwischenablage  
Edit>Copy  Kopiert den markierten Bereich in die Zwischenablage 
Edit>Paste  Fügt den Inhalt der Zwischenablage an der aktuellen Cursorpo-

sition ins Algebrafenster ein 
Edit>M ark and Copy Markiert einen rechteckigen Bildschirmausschnitt und kopiert 



ihn in die Zwischenablage. (Nach dem Anwählen von E-
dit>M ark and Copy klickt man mit der linken Maustaste die 
gewünschte linke obere Ecke des zu markierenden Rechtecks 
an und bewegt die Maus bei gedrückter linker Maustaste zur 
gewünschten rechten unteren Ecke. Loslassen der linken Maus-
taste bewirkt, dass der Inhalt des aktuell markierten  Rechtecks 
in die Zwischenablage kopiert wird.) 

 
Im Graphikfenster: 
 
Edit>Copy Plot Window  Kopiert ein Bild des gesamten Graphikfensters in die Zwi-

schenablage 
Edit>M ark und Copy Wie im Algebrafenster   
 
 
Außerdem besteht in allen Fenstern die Möglichkeit, durch Drücken der PrtSc Taste, den 
kompletten Bidschirminhalt (mit allen aktuell sichtbarenTitel- und Menüleisten) bzw. durch 
Drücken der Tastenkombination Alt + PrtSc ein Bild des aktuell geöffneten Fensters (samt 
Titel- und Menüzeile) in die Zwischenablage zu übertragen. 
 
 

11.3 Drucken von Inhalten des Algebrafensters 
 
 
Anklicken des Drucker-Symbols in der Befehlsymbolleiste bewirkt, dass der gesamte Inhalt des 
Arbeitblattes ausgedruckt wird.  
   
Will man nur Teile des Arbeitsblattes drucken, so sollte man statt des Drucker-Symbols den 
Menüpunkt  File>Print  anwählen. In diesem Fall erscheint vor der Ausführung des Druckbe-
fehls ein Dialogfeld, das es ermöglicht, 

- Optionen des verwendeten Druckers, 
- den Druckbereich (das gesamte Arbeitsblatt / nur bestimmte Seiten / nur die aktuell 

markierten Bereiche), 
- sowie die Anzahl der gewünschten Kopien pro Seite auszuwählen . 

 
Es ist empfehlenswert, vor dem Drucken mit File>Print Preview die Druckbildvorschau auf-
zurufen und gegebenenfalls mit Options>Printing  Änderungen im Layout des geplanten Aus-
drucks vorzunehmen.     
 
Anwählen von Options>Printing  führt auf die folgenden Untermenüpunkte: 
 
Expression Layout Schriftart und Schriftgröße der mathematischen Ausdrücke; Ent-

scheidung ob die Zeilenkommentare bzw. Rechenzeiten gedruckt 
werden sollen    

Header and Footer Gestaltung der Kopf- und Fußzeilen (Inhalt, Anordnung, Schrift-
art, Schriftgröße) 



Page Setup Festlegen der Größe der Seitenränder 
Printer Setup Verändern von Druckereinstellungen 
    
     

11.4 Drucken und Speichern von Bildern 
 
Anklicken des Drucker-Symbols bzw. Anwählen des Menüpunktes File>Print  in einem Gra-
phikfenster bewirkt, dass der gesamte Fensterinhalt gedruckt wird. 
 
Auch hier besteht die Möglichkeit, mit File>Print Preview die Druckbildvorschau aufzurufen 
bzw. mit Hilfe von Options>Printing  das Layout des geplanten Ausdrucks zu beeinflussen.  
 
Außerdem kann man den Inhalt eines Graphikfensters mit Hilfe des Menübefehls  
File>Export  als Grafikfile abspeichern. Zur Auswahl stehen die Grafikformate DIB , JPEG, 
Targa und TIF F.  
 


